Find the answer to your Linux question:
Results 1 to 8 of 8
I am using mandrake 10.1 and I am trying to get my usb mp3 player to be noticed by the system, but it doesn't auto mount . How do i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6

    mounting USB MP3 Player


    I am using mandrake 10.1 and I am trying to get my usb mp3 player to be noticed by the system, but it doesn't auto mount . How do i fix this? And another question, is there any media players for linux that supports copying songs to mp3 devices similiar to wmp?

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    I have one myself. Here is how this works:

    Your /dev/sda1 file is your USB port. You will also need a mount point. I use the directory /mnt/usb. Decide on a mount point and create the file (put it in the /mnt directory, for convenience).

    Now, you have to mount the device. This is easily done:

    Code:
    mount /dev/sda1 /mnt/<MOUNT POINT>
    In my case, I use:

    Code:
    mount /dev/sda1 /mnt/usb
    Now then, this can get annoying after a while, so you'll want to make it simpler. This is also easy. The /etc/fstab file is what contains your mount information. So in your case, you want to add a line for the USB device. I'll show you mine, and I'll tell you what you'll want to modify:

    Code:
    /dev/sda1 /mnt/usb auto noauto,users,rw 0 0
    You will want to change "/mnt/usb" to whatever your mount point it.

    What this line does is simple:

    The first section is the device you are mounting.
    The second is where you are mounting to.
    The third is the filesystem type (in this case, automatically determined).
    The fourth are mount options. "noauto" means "don't boot me at startup". "users" allows all users to access it. And "rw" gives read/write permissions.
    The fifth and six variables are used to determine things with other apps. These will usually be "0 0" unless it is a part of the base filesystem.

    Once you have a line in the fstab file, you can simply run the following:

    Code:
    mount /mnt/<MOUNT POINT>
    
    or
    
    mount /dev/sda1
    Either of these will mount correctly. You can then navigate to the folder as usual, and do whatever you want. If you're using GNOME, there's a mount applet that you can use. Just put in "/dev/sda1" into the option, and you can mount/unmount at will by clicking.


    ONE LAST IMPORTANT THING:

    Before you unplug the device from your USB port, you MUST umount the device (yes, that is the correct spelling). To do this:

    Code:
    umount /mnt/<MOUNT POINT>
    This unplugs it from the system. If it tells you that the device is busy, you can use the command:

    Code:
    fuser -k /mnt/<MOUNT POINT>
    To automatically kill whatever is using the device.


    I hope this helps! Post again if you need any help.


    EDIT:

    For the record, this will not AUTOMATICALLY mount the device. But this will let you manually do it. For automatic mounting, you'll need to look at specifics of the WM you're using. I know that GNOME has a mount applet, and I know that KDE has some sort of default mounter thingy. SuSE enables it by default, but I don't know how to access it automatically.

    Also, I don't understand what you mean by the second question. Can you clarify?

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    worked like a charm! ... but, now anytime i try and browse folders with konqueror after the usb has been mounted, it just hangs and wont open anything... any idea?

  6. #5
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Hrmm...as in, you mount the USB device, open konqueror, and click on some folder, and nothing happens? That's very weird indeed...

    Or do you mean that you click on the USB folder and nothing happens? If this case, it might simply be loading...do you have a lot of files/directories in there?

    Hmm, I honestly don't know... you might want to search the official KDE forums or search these forums to see if anyone else has had this problem.

  7. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    The konqueror not working problem is due to a runaway process occuring in Mandrake 10.1 when USB storage devices are mounted. To fix it, get into the task manager (e.g. KDE system guard) and kill off the process which is taking the most resources (usually near 90%).

    The other option is to use nautilus as your file manager

  8. #7
    unknown
    Guest

    Linux fails to recognise usb mp3 player

    ATMEL 256M USB mp3 player works in wind2K wind98(with supplied driver) and NOT in Linux (there is no sda1..sda4, no scsi recognised) so none of the above methods work.

  9. #8
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Heres what you can try:
    1. turn off the computer
    2. plug in mp3 player
    3. turn on computer

    then follow cabhan's steps for mounting it. The above steps force mandrake to search for new hardware upon boot, and for some reason it does it this way and not automatically when KDE is running.
    Life is complex, it has a real part and an imaginary part.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •