Find the answer to your Linux question:
Results 1 to 7 of 7
When I plug in my pen drive (an Integral 128Mb one that says it's Linux compatible) my computer either: a) freezes untill I power off b) i can Code: mount ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110

    My pen drive crashes my computer!


    When I plug in my pen drive (an Integral 128Mb one that says it's Linux compatible) my computer either:
    a) freezes untill I power off
    b) i can
    Code:
    mount /dev/sda1 /mnt/rem
    as root, but when I try to copy anthing to/from it does a) or says I/O error and decides the device doesn't exist

    Oh, and the mouse will only go sideways if b) happens.

    Please help, my floppy drive is dysfunctional too, so my pen drive is my only way to transfer files!

  2. #2
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    If it helps, I had this prob with Mandrake 10.1 now with 2005 (10.2).

    Please help!

  3. #3
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Take a look here:

    http://www.linuxforums.org/forum/topic-41723.html

    See if that solution helps at all.

  4. #4
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    Pretty much do that anyway.

    It sorted itself out for a while strangely

    I'll try adding it to my fstab, see if it helps...

  5. #5
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    nope, it's gone strange again

    i've tried Ubuntu too and that freezes when I put the drive in.

    I've found out that by disabling hald and hotplug and doing
    Code:
    mount /dev/sda1 /mnt/rem
    I can get it to work a bit, but my mouse still will only go sideways.

    Does anyone know if it might be a hardware prob?

  6. #6
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Do you have a read-only switch on the side of the pen-drive?

    On an old key I had when read only was turned on it did pretty strange things like not mounting, registering as a different partition (sda2 instead of sda1 etc) or sometime just not responding at all.

  7. #7
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    It does have a readonly swith, but I've never used it - its set to read/write.

    There is one strance feature: It functions as a floppy drive and a pen drive.

    I've recently installed SUSE 9.2 (Free version) onto my computer. The pen drive still makes computer freeze.

    I have also tried using a SUSE 9.2 live CD on a different computer, and the drive didn't crash the computer. It didn't auto-mount the pen drive section, but it recognised it, and the floppy drive worked straight off.

    Please help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •