hello,

I have mandriva le 2005 installed. I am trying to install the latest ati drivers. I have found some guides online that explain how to do this.. I have followed them with no luck. here is what I have done...

------------------------------------------------------------------------------------
**Upgrading X.Org to 6.8 in Mandrake 10.1

I do not recommend updating all packages. Do so at your own risk.

Go to Software media manager then add http://rpm.nyvalls.se/10.1/RPMS/ as an HTTP site or Type this in a console. You have to be root to do the installs, type :

code:

su


Enter the root password then type:

code:

urpmi.addmedia thacs.rpms http://rpm.nyvalls.se/10.1/RPMS with hdlist.cz



Next type

code:

urpmi xorg



A list of about 10 packages will be displayed. Choose the package you want to install *Let's just say its xorg-x11* then type:

code:

urpmi xorg-x11



A list of Dependency files will display, you need to download these as well, Type Y and hit enter and the packages should install and you have successfully upgraded X.Org to version 6.8

Installing ATI drivers:

Download your flavor of the ATI driver RPM http://ati.com/support/driver.html and place it into a directory of your choice.

Now cd in to the directory you put the ATI Driver rpm package in.

Type

code:

rpm -Uh --force <ati_package_name>.rpm



You should see the install run. Next type:

code:

fglrxconfig



Answer all the questions as prompted

When asked to generate an xorg.conf file, answer y

Restart and log into X-Windows

Testing and trouble shooting:

To insure the driver is installed type

code:

fglrxinfo



Look for the OpenGL vendor string it should say ATI Technologies Inc. If it says MESA Indirect (software) rendering, there are a couple things you need to check.

1) Make sure you have the Kernel source code and the GCC compiler installed, by default they are not.

2) The ATI driver has its own internal AGP management for Intel chipsets. If you don't have an Intel chipset, you may need to change the "UseInternalAGPGART" option to "no" in the device section of the xorg.conf.

If you found you missed a step (like no kernel source code) you can simply reinstall the ATI driver. You should not have to run fglrxconfig unless you feel you made a bad choice in your options.

If everything seems to be fine you can type

code:

glxgears



to get a VERY rough framerate benchmark, note it is not a true benchmark but it is good for reference. If everything is working properly you should have a framerate at least 10,000 and up to or over 50,000 depending on your hardware. Mesa drivers are normally 1000 or under.

This information was put together by the posts of several people as well as the instructions for installing from ATI. I mainly just put them into a single post to simplify the install. Please let me know if there are any corrections that need to be done to this How To document.

-------------------------------------------------------------------------------------

I have done all this, but I still come back to having the mesa opengl stuff. My glxgears is roughly 400fps.. which means I have no 3d acceleration. How do I solve this problem? I have a radeon 9600 pro, athlon 64 2800, 1 gig ram.

thanks for any suggestions.