Find the answer to your Linux question:
Results 1 to 3 of 3
first I could only play audio cd as root, and not as user. I tried several things, and the last thing I tried (at someone's suggestion) was chown $user /dev/sdb. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    9

    cdrom doesn't work at all anymore


    first I could only play audio cd as root, and not as user. I tried several things, and the last thing I tried (at someone's suggestion) was chown $user /dev/sdb. After that, I couldn't play audio cd even as root anymore. On top of that, I lost the CD icon on my desktop (as user and root), and my machine won't recognize data CDs as user and root anymore. I don't know how to put it back and how to get CD to work. Help?

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    I'm not familiar with using chown in that way (though it might be okay?). I would try this.

    I'll assume your user name is ted ... okay:
    su
    yourpassword
    chown ted : ted /dev/sdb

    If you have a lot of subdirectories, using chown to change things recursively is good. If I remember correctly (I'm not using a Linux box right now) this would be:

    chown -R ted : ted /dev/sdb

    Try that, and if it fails I'm very sorry
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    9
    Is there any way I can bring back the existence of the CD itself? Root doesn't even recognize it. It's like it disappeared. My CD is also designated as hdc, not sdb, so I am a little concerned about that designation. Isn't that a designation of a scsi device? If I can at least bring back the CD that would be great. I am windows based, so I don't know how to make the transistion just yet. The hardware configuration sees the CD rom, but that is about it. Nothing else recognizes it, and now I can't even read data CDs. Any suggestions?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •