Find the answer to your Linux question:
Results 1 to 10 of 10
I don┤t think I changed anything. My flashdisk always worked like my cdroms, when I connect it a icon automatically appears on my desktop and it is automatically mounted. No ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32

    USB flashdisk


    I don┤t think I changed anything. My flashdisk always worked like my cdroms, when I connect it a icon automatically appears on my desktop and it is automatically mounted. No problems. When I removed it, the icon dissapears. Now I can┤t get it to supermount. I changed all the settings I could in Ęconfigure your computer, mount points sectionĘ. I also tried editing my etc/fstab file. Now I must explicidly mount it each time at Ęconfigure your computer, mount points sectionĘ. And worse, if I try to copy anything to my flashdisk konquerer tells me access denied. Can anyone please help me?

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Could you please paste your /etc/fstab file here?

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32
    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    /dev/sda1 / ext3 defaults 1 1
    /dev/sda6 /Media ext3 defaults 1 2
    /dev/sda7 /home ext3 defaults 1 2
    none /mnt/LOLA supermount dev=/dev/sdb1,fs=vfat,--,umask=0,user,sync 0 0
    /dev/hdf /mnt/cdrom auto umask=0,user,iocharset=utf8,noauto,ro,exec,users 0 0
    /dev/hdh /mnt/cdrom2 iso9660 user,iocharset=utf8,noauto,ro,exec 0 0
    none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=utf8,sync 0 0
    /dev/hdc1 /mnt/win_c vfat umask=0,iocharset=utf8 0 0
    /dev/hde1 /mnt/win_c2 vfat umask=0,iocharset=utf8 0 0
    /dev/hdg1 /mnt/win_c3 vfat umask=0,iocharset=utf8 0 0
    /dev/hde5 /mnt/win_d vfat umask=0,iocharset=utf8 0 0
    none /proc proc defaults 0 0
    /dev/sda5 swap swap defaults 0 0

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    I assume this is your flash drive:
    none /mnt/LOLA supermount dev=/dev/sdb1,fs=vfat,--,umask=0,user,sync 0 0
    [code]none /mnt/LOLA supermount dev=/dev/sdb1,fs=vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0[code]

    try that and see how it goes.[/code]

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32
    Do you mean change it to:
    /none /mnt/LOLA supermount dev=/dev/sdb1,fs=vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0

  7. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    yes

  8. #7
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    yes

  9. #8
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32
    I just tried that and the situation stays the same?

  10. #9
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    try this, delete the line in fstab concerning the usb flash drive
    turn off your computer.
    plug in the usb drive,
    turn on the computer
    see what happens.

    I know this sounds like a series of windows style instructions, but thats all i can think of to force Mandriva to redetect the drive with what it thinks should be the correct parameters.

  11. #10
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32
    Thanks AlexK that actually worked. Everything is working fine again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •