Find the answer to your Linux question:
Results 1 to 4 of 4
On my mandrake, how can i configure multimedia keyboard to control the PCM volume and not the Master....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    9

    How to enable the multimedia keyboard to control the PCM vol


    On my mandrake, how can i configure multimedia keyboard to control the PCM volume and not the Master.

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    If you look into KDE control centre you should see KHotkeys under system. This is what is pointing your multimedia keys to Kmix. (Assuming KDE here...).

    You can go into the Mentor Wireless settings, because they do the mapping for pretty much all of the keyboards. You will see increase volume and decrease. Theses are configured to do a DCOP call to Kmix, essentially a direct API to the application. Run KDCOP when you are there and browse the settings for Kmix. Kmix should be running for this so it can be queried. Your end setting should be of the form -

    kmix
    Mixer0
    increasePCM
    1

    where DCOP calls Kmix, under Mixer0 remote object, asks for PCM increase in increments of one. I'm not sure if increasePCM is correct (On an XP machine right now) but if you're using KDCOP you should find some settings to suit your need. Don't be afraid to experiment before you press apply, just use the 'try' button to see if it works.

  3. #3
    Linux User eugrus's Avatar
    Join Date
    Dec 2004
    Location
    Russia
    Posts
    391
    Russian UNIX Forums
    http://eugrus.pp.ru

  4. #4
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    Those links are pretty good, but remember that the inbuilt KHotkeys is an extension of lineak. What should be remembered is that this is a way of overlaying two keyboard configs, if you don't mind a challenge you're better off configuring a whole keyboard definition. The default setting for multimedia keys is usuall the same as the Trust Multimeida Kb. Try that and mess around with it. It's info is under 'inet'.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •