Find the answer to your Linux question:
Results 1 to 3 of 3
Ok, ive been on these forums since i switched to linux about 2 months ago but never really got around to signining up (figured id try to figure it all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    3

    No DrakX tools working...


    Ok, ive been on these forums since i switched to linux about 2 months ago but never really got around to signining up (figured id try to figure it all out by myself so i can learn faster... didnt work...) but now when trying to update my kernel something happened... i tried to install some file (forgot which one) that had to do with drakx and it made all of the drakx things stop working (mcc, rpmdrake, harddrake2, ect... those things...) and ive been trying to fix it and cant figure it out... When i try to open one, i get this:

    Code:
    [montez@localhost montez]$ mcc
    Can't load '/usr/lib/libDrakX/auto/c/stuff/stuff.so' for module c::stuff: /usr/lib/libDrakX/auto/c/stuff/stuff.so: undefined symbol: PL_sv_undef at /usr/lib/perl5/5.8.3/i386-linux-thread-multi/DynaLoader.pm line 229.
     at /usr/lib/libDrakX/c.pm line 5
    Compilation failed in require at /usr/lib/libDrakX/c.pm line 5.
    BEGIN failed--compilation aborted at /usr/lib/libDrakX/c.pm line 5.
    Compilation failed in require at /usr/lib/libDrakX/run_program.pm line 5.
    BEGIN failed--compilation aborted at /usr/lib/libDrakX/run_program.pm line 5.
    Compilation failed in require at /usr/lib/libDrakX/common.pm line 7.
    BEGIN failed--compilation aborted at /usr/lib/libDrakX/common.pm line 7.
    Compilation failed in require at /usr/bin/mcc line 28.
    BEGIN failed--compilation aborted at /usr/bin/mcc line 28.
    [montez@localhost montez]$
    and the stuff.so is there in /usr/lib/libDrakX/auto/c/stuff/so.so and someone told me perl wasnt installed but it is and i have the latest version... Im on Mandrake 10.0 Community and my uname -a gives me this:

    Code:
    Linux localhost 2.6.3-7mdk #1 Wed Mar 17 15:56:42 CET 2004 i686 unknown unknown GNU/Linux
    oh yea, i more thing... I dont have my CD drive anymore. Some unfortunate accidental stepping-on broke it so i installed a urpmi of the "main" media as a replacement. And i have a "contrib" media too... both off of rutgers (not sure if thats important, just trying to give all the information that may help...) If anyone can possably help it would be much appreciated because this is driving me crazy. Im new to linux so kinda need those tools for now. And when i try to uninstall all the drakx tools (so i can re-download them and re-install them...) it keeps saying other things need the drakx tools so im scared to mess up something more... Thanks for reading this, and sorry for rambling on about stuff that probly isnt important to helping...

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    3
    hhmmm... anyone know the files that are used by these tools? i could just remove them all and re-download them... maybe i have conflicting versions of diffrent files? trying to do a mkinitrd gives the same error (but still makes the initrd file... lucky for me...)

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    3
    nobody?! come on! lol... just post something that might possably work! i got the kernel installed (YAY!) but this problem is still killing me... someone please help!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •