Find the answer to your Linux question:
Results 1 to 9 of 9
As a linux newbie I am particularly mystified with a problem I am having with my mouse under Mandrake 10.1 download edit. and KDE 3.2 where my mouse fails to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Location
    England
    Posts
    1

    Mouse settings forgotten after each boot


    As a linux newbie I am particularly mystified with a problem I am having with my mouse under Mandrake 10.1 download edit. and KDE 3.2 where my mouse fails to work after each boot up of the system, until I change the settings using the mouse. A detailed description of my first linux journey lies below.

    1. The mouse worked perfectly during the installation routine.
    2. I rebooted I found that the system would not respond to the mouse at all. Using the shortcut keys in KDE I managed to open up the system config and proceeded to set the mouse option to the ps2 ms explorer mouse, (I am using a Microsoft Wireless Intellimouse Explorer 2 plugged into a ps2 port via a USB adapter, but the signals coming from the mouse are the same as any other, I think.).
    3. Nothing happened, the mouse still didn't work.
    4. On the second attempt the mouse test screen appeared and the my mouse functioned properly.
    5. Upon rebooting the mouse failed to work again and it seems I have to go through this procedure upon every boot.
    6. I read somewhere that I had to scroll the mouse wheel to activate it, but this doesn't seem to work.

    I am probably missing something really obvious here. Please will someone more experienced than I spare some time to bestow some wisdom upon this linux virgin

  2. #2
    Just Joined!
    Join Date
    Jun 2005
    Location
    New Jersey
    Posts
    49
    Ummmmmm I dont wana seem like text support but is it plugged in?
    Also I dono it might not be probing it correctly.
    Stick to the ps/2 mouses

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    2
    I had this problem when I first installed Mandriva with security setting "Paranoid". To fix it, I simply re-installed Mandriva with a security setting of "Standard". I'd just try setting the level to Standard without reinstalling, though.

  4. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Just a guess, being that I don't use a wireless mouse, etc: Is it possible that when the mouse has not been detected that it may have been because the mouse itself was not in "communication" with it's receiver? If the mouse isn't detected at the right time during booting, it may not get properly configured. I have found gpm to be useful in troubleshooting mouse issues: gpm is a mouse application that works in the text console. Run 'man gpm' or 'info gpm' for more information. If you can get it to work in the text console, it will help in getting it to work in X windows.
    /IMHO
    //got nothin'
    ///this use to look better

  5. #5
    Just Joined!
    Join Date
    May 2005
    Location
    Dallas, Texas
    Posts
    95
    I had the same problem with mandrake 10.1 and a serial mouse. Each time I configured it it would work until reboot. Then it would only work if I plugged a ps2 mouse in. I found if I configured the mouse using xf86cfg and saved the changes it would finally stick.

    FYI, this didn't happen any more when I installed 10.2.

  6. #6
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    207
    I'm not asking for help, but yet i'll tell a bit something that happens to me too. In average, once a week, if I let my Mandriva 2005 LE for too long (half a day), when I come back, sometimes, the mouse does not exist anymore : the system does not recognize it. I may run mcc through keyboard shortcuts, and go into the mouse menu, that won't change anything, only starting a new session can solve it. So, what I mean, is that the mouse may be "lost" even after boot-time.
    I don't even hope that it can help, but just in case, I posted it

  7. #7
    Just Joined!
    Join Date
    Jun 2005
    Location
    San Francisco, CA
    Posts
    54
    My questions at this point would be where does Mandrake keep its mouse settings?

    I'd try putting something into that/those file(s). Perhaps into /etc/X11/xorg.conf with xf86cfg, or into whatever file holds console mouse info however one does that. If it's ignored by Linux, that's one kind of problem, and if the config files mysteriously "loses" the info, it's another.

  8. #8
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Have you tried manualy editing the /etc/X11/xorg.conf file? and add the changes for your mouse?
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  9. #9
    Just Joined!
    Join Date
    May 2005
    Posts
    52
    flyingtalkingdonkey:

    I had the exact same problem, here is what I did to fix it:

    check /etc/X11/Xorg/Xorg.conf you should find a line that lists :

    /dev/ps2mouse or similar

    change that to:

    /dev/psaux

    that should do it, post feedback either way

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •