Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    chage: can't lock password file


    Hi, I'm having a problem running chage on my server all of a sudden, msec which runs every hour is crapping out because it can't run it and /var/log/auth.log filling up with chage: can't lock password file and can't lock shadow password file. If anyone has an idea of how to fix this please let me know, I will really appreciate it, thanks.

  2. #2
    What user permissions does that job use? If I remember correctly, chage (which changes password aging parameters) requires full root access.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  3. #3
    -rwsr-xr-x 1 root root 32600 Feb 24 2003 /usr/bin/chage*
    SUID has not been removed but I don't think that has anything to do with it, if it helps I had to reboot the server a few days ago, this problem didn't start until after a day after rebooting, but might be related, any suggestions..

  4. $spacer_open
    $spacer_close
  5. #4
    Do you get the same problem if you run chage manually as root?
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  6. #5

  7. #6
    Do you actually have an /etc/passwd.lock file or /etc/shadow.lock file present?
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  8. #7
    no both are not there.

  9. #8
    What is your system's security level set as?
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  10. #9
    can you tell me how i can check what the system security level is set at?

  11. #10
    Open Mandrake Control Center. At the top of the window, click on Options and select Expert mode. Then you can click on the Security tab and select the module there (it should be the first one).

    Alternately, you can open the /etc/sysconfig/msec file and look at the SECURE_LEVEL= variable.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •