Find the answer to your Linux question:
Results 1 to 6 of 6
Hi I've just downloaded mandriva's free version of le 2005 to try linux, after using windows for many years, so complete noob. The problem I have is when using the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Location
    UK
    Posts
    8

    Shutdown Mandrake 2005 and loose network connection??


    Hi

    I've just downloaded mandriva's free version of le 2005 to try linux, after using windows for many years, so complete noob.

    The problem I have is when using the halt, shutdown or crtl,atl,del commands to shut down, I loose connection to my wired network. It's as if it turns off the ethernet connector (marvell 88E8001) on the motherboard (Asus AV.

    The only way to regain connection is to reboot back into linux. If I boot into windows, the network adaptor stays off, so no internet connection.



    I can the connection light on my router going off and coming back on as I shutdown and reboot linux.

    Is there something I'm doing wrong, or is there something to configure.

    Thanks for your help
    travd

  2. #2
    Just Joined!
    Join Date
    May 2005
    Location
    Dallas, Texas
    Posts
    95
    I'm not really sure what is happening here, but I have some ideas that I think are worth trying. I'd probably just try one at a time, and switch back if a change doesn't fix the issue. Of course, if one of the items fixes the issue, I would stop there.

    1) Change the ACPI/Power Mgmt settings in Bios for the nic card. If they are on, turn them off, or vice versa.
    2) Check/uncheck the "Enable ACPI" box under Boot/Set Up How the System Boots in Mandrake Control Center ("Configure Your Computer").
    3) Same place as item 2 above, but try a different boot loader (if Lilo, try Grub).

    I hope this helps. Post back what you find.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Location
    UK
    Posts
    8
    Hi

    Thanks for reply. I tried using grub as bootloader, enabling acpi and forcing no acpi. Didn't solve the problem though

    I couldn't find an option for the nic card in the bios power managment settings.

    I don't think the problem is to do with the bootloader. More the boot up/shut down sequence?

    As mandrake loads, if I press esc for "verbose" mode I can see that the lines that correspond with the router light going on/off

    Bringing up interface eth0:

    Shutting down interface eth0.. eth0 network connection down

    I know that eth0 is the marvell chip, so this makes sense

  4. #4
    Just Joined!
    Join Date
    May 2005
    Location
    Dallas, Texas
    Posts
    95
    Sorry none of this fixed your problem! Maybe someone who knows more about what is going on here will chime in and offer some more suggestions.

    Quote Originally Posted by travd
    I don't think the problem is to do with the bootloader. More the boot up/shut down sequence?
    I'm not an expert so I can't say for sure. The reason I suggested the bootloader was I had a problem with Mandriva 10.2 on one machine where it wouldn't power down. I could see the command being sent in verbose mode, and could hear the HD spinning down, but the PC power never turned off. I had to power off manually at the end of the shutdown sequence. I ended up fixing this by changing the bootloader from lilo to grub, of all things...

  5. #5
    Just Joined!
    Join Date
    Apr 2005
    Location
    India
    Posts
    11
    have a similar problem here, but i have VIA ethernet card. if i reboot from linux into windows(i rarely do this), i've no connection. What i did to solve it is, unplug the cable modem, and put it back in after a few secs. it works. dont know this is wat u mean...

  6. #6
    Just Joined!
    Join Date
    Jun 2005
    Location
    UK
    Posts
    8
    Even turning off power to the modem, router and computer won't fix it. It's like the onboard lan has been switched off in the bios.

    I've tried installing the latest marvell driver for the kernel version, and changing the network script /etc/rc.d/init.d/network to point away from ifdown, but it still manages to shutdown the lan.

    Will try a pci ethernet card tomorrow.

    travd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •