Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 24
In my case I had nthe incorrect source kernel installed. oops I woun up just using madwifi and following it's instructions and at reboot I went to the MCC . ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2005
    Posts
    19

    modprobe


    In my case I had nthe incorrect source kernel installed. oops
    I woun up just using madwifi and following it's instructions and at reboot I went to the MCC . When I selected the modem/run config (in hardrake) I was offered the Atheros WIFI driver as a choice. This only occured after the madwifi install and a reboot.
    If you do not have that as an option in your hardrake config please walk me (us) threw what you've done and where you're getting stuck.
    We'll help you as best as we can

  2. #12
    Just Joined!
    Join Date
    Jan 2005
    Posts
    39
    I dowloaded madwifi and then tried to folllow the instructions given in INSTALL
    ie I did
    trouble% KERNELPATH=/usr/src/linux-2.6.3
    trouble% make

    It looked like it worked. but then the modprobe command said there was no ath_pic module!
    I tried rebooting the machine. and configuring using hardrake but htat didnt work either.

    In the hardrake command it gave me Intel corp thing as an option in the run config option. Which I think is my ethernet card.

    Any ideas on what I can do?
    thanks
    rekha

  3. #13
    Just Joined!
    Join Date
    Jul 2005
    Posts
    19

    MADWIFI setup

    Try these instructions
    http://madwifi.sourceforge.net/dokuw...hp?id=mandrake
    this is what I eventually did to work.
    Maybe I should publish a HOWTO?!
    lemme know
    joex

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Jan 2005
    Posts
    39
    well I did exactly what you said or htat website says and even after rebooting there is no ath_pci module!

    not sure what to try

  6. #15
    Just Joined!
    Join Date
    Jul 2005
    Posts
    4
    You poor, poor, pathetic slug-shaped-pomegranites.

    Sorry about that. But it had to be said.

    I've heard too many complaints about this to listen to this junk any longer.

    OBSERVE!

    I have really changed up the madwifi dokuwiki page, and added a new guide to it, which was built around a very helpful post which could have easily been found had any of you actually taken the effort to actually search for a while.

    So to see the new dokuwiki page with the many changes in structure, contents, and design I've made to it, go to the same URL, here:

    http://madwifi.sourceforge.net/dokuw...hp?id=mandrake

    That page should now tell you everything you need about getting wireless up on Mandrake Linux.

  7. #16
    Just Joined!
    Join Date
    Jan 2005
    Posts
    39
    well its possible am just dumb..but really followed the instructions from that page.
    there still is no ath_pci module

  8. #17
    Just Joined!
    Join Date
    Jul 2005
    Posts
    4
    No estas dumb

    You're not dumb, you've just got un-cooperating hardware. If you can't read ath_pci, it means your computer just doesn't know the module exists, or it doesn't exist.

    Don't be silly, Whether or not your hardware is compatible or easily functional with your computer is not related at all to your level of intelligence. You're not dumb. You're just self-centered, and you have a hardware problem.

    go into console, type 'su' and the root's password to become root

    Type
    /sbin/cardctl ident
    if it says "no product info available.", it means your computer is not reading your card, and your card just isn't an Ath0 wireless card. If it says in product info something other than "atheros" it may mean that your card just isn't an ath0 wireless card. That can happen, although rarely. It SHOULD say later in the product info something like "wireless LAN reference card". If not, that's not a wireless card you're using there, buddy.

    If you get atheros, and "wireless Lan card" or something of the sort, try
    ifup ath0
    if nothing shows up, or if it says something like 'no card' or such, it means your computer is not reading a card.

    If it did try to get an IP but couldn't accomplish it, go on.

    Now, go into console. Enter
    urpmi kernel-source gcc cvs
    press return. If it says "everything already installed" you're good. If it says "GCC can be installed from the following packages" and so on, it means your computer doesn't know about some of you installation media. See the bottom of the wiki page, the appendix part.

    If you have everything installed, try restarting your computer, and itry to configure your card from the madrake control center. You should be able to.

    If everything already is installed correctly for sure, and ifup ath0 tries to get an IP but just can't get one, and cardctl/sbin ident gets ath0 and "wireless card" and restarting and actually trying to configure the card doesn't help; it just means that you're just using an incompatible card. It happens. Try to get an external one soon. I suggest somethisg like a DWL-G650 or above/better/later versions.

    In fact, it's beginning to look like your card is very much not compatible with the drivers on the internet today... Take a quick glance at this if you haven't already:

    http://www.google.com/search?hl=en&q...=Google+Search

    It seems to be that your internal wireless card isn't working. But that's fine. It might take a bit longer then you may like, but I'm sure you could easily and cheaply get an external one. My internal wireless card has never worked, not even on windows, and I can say from experience, It's not too much of a problem or a hassle to use an external wireless card. (Not as in USB connected, but as in for the wireless card slot on the side of your laptop) I know, I know, "but I'd save money switching back to windows". Trust me, linux is well worth the extra $10, 20, 30 occasionally necessary to get a compatible wireless card.

  9. #18
    Just Joined!
    Join Date
    Jul 2005
    Posts
    19
    great link!
    Please post your reults if that doesn't work. Something like
    I entered root!@xxx XXXXXX
    and the console spit back
    XXXXXX
    so we know `what' doesn't seem to be working.

  10. #19
    Just Joined!
    Join Date
    Jan 2005
    Posts
    39
    Ok,
    Turns out I did do something stupid. . Didnt do the right thing when I had to copy the lib/modules ,,,
    But it still doesnt work. The kernel version I have is 2.6.8.1-12mdk but the source file that gets loaded is linux-2.6.11-6mdk.
    I am not sure how much difference this makes but now when I was doing the files copying command this is what I did
    cp -rf /lib/modules/2.6.11-6mdkcustom/net/* /lib/modules/2.6.8.1-12mdk/kernel/net/

    When I follow all hte commands (not making any mistakes!)
    this is what I get
    [root@localhost madwifi]# modprobe ath_pci
    WARNING: Error inserting ath_hal (/lib/modules/2.6.8.1-12mdk/kernel/net/ath_hal.ko): Invalid module format
    WARNING: Error inserting wlan (/lib/modules/2.6.8.1-12mdk/kernel/net/wlan.ko): Invalid module format

    Now what to do ? I am really bad at this but would hate to switch to windows.

    rekha

  11. #20
    Just Joined!
    Join Date
    Sep 2005
    Location
    Peru
    Posts
    3

    Talking about a simple solution ...

    Hola Gente ...

    Just a few lines to say something about me. As you may supouse English is not my mother tongue ... so pls dont get mad about my writing.
    The day before yesterday i had my first contact with linux, cause i had to with some old ATM switches ... so it was imperative to logg me into the NMS for that switches (the NMS runs on SPARC, by the way i dont know a thing about Solaris).
    When i installed Mandrake 10.1 on my Tosh A75 S211 everything goes fine. At first sight touchpad, video, NIC everything workred out fine. And then the disaster my W-NIC didnt work.
    So i stared to look around into the linux world ... it make me feel very i mean very stupid ... and then i found this forum and i red ligne and skizor conversation. Skizor sugested this link

    http://madwifi.sourceforge.net/dokuw...hp?id=mandrake

    For a start i followed the guide step by step but nothingh happend

    When i tried to load the driver, i got this msg:

    [root@localhost home]# modprobe ath_pci
    FATAL: Module ath_pci not found.

    Then i started to dive into the Mandrake file system and I found that 9 *.ko files where generated at:

    /lib/modules/2.6.8.1-12mdkcustom/net/

    at the time i issued the following:

    cd madwifi
    make
    sudo make install

    # Pls forgive me if my lng sounds too simple and obious but remember its # my 3th day whit linux.

    In the first guide some body says that we had to do this:

    cp -rf /lib/modules/2.6.11-6mdkcustom/net/* /lib/modules/2.6.11-6mdk/kernel/net/

    #Taking care about our own kernel version. Yesterday i foundout what #kernel was.

    Then i did

    cp /etc/modprobe.conf /etc/modprobe.conf_backup
    echo "alias ath0 ath_pci" >>/etc/modprobe.conf


    But when i issued:

    depmod -a

    I realized that this comm generates a kind of lib. where it declares all its alviable modules

    modules.dep

    In my case this file was located at:

    /lib/modules/2.6.8.1-12mdksmp/modules.dep

    When i edited modules.dep, i realized that here i could find a reference for all drivers and modules but ath_pci

    In modules.dep, i found a reference for "airo_cs.ko.gz" located at:

    /lib/modules/2.6.8.1-12mdksmp/kernel/drivers/net/wireless/

    # At this point i remembered my DOS times when i was at elementary #school ... here is what i imagine in order to resolve that problem.

    1.- "airo_cs.ko.gz" is some file associated to CISCO Aironet Wi-Fi device.
    ---------OK
    2.- Why they have this .gz?
    -----------They are compressed in GZip; Ok then
    3.- Lets compress the 9 files that were generated when i make

    sudo make install

    they were at:
    /lib/modules/2.6.8.1-12mdkcustom/net/

    4.- Lets use Ark to compress each file ---- DONE
    5.- Now that i had the 9 file compressed i placed them into:

    /lib/modules/2.6.8.1-12mdksmp/kernel/drivers/net/wireless/

    6.- Lets try again:

    depmod -a

    ---------now i have "ath_pci.ko.gz" into modules.dep

    7.- Lets issue


    [root@Daredevil madwifi]# modprobe ath_pci
    ---------------NO ERRORS ......................

    8.- OK OK OK OK OK just too good to be true ....
    9.- RESETEEMOS ESTA MICHI .... A VER QUE PASA
    10.- Creo que no hacia falta la reseteada, .... sorry in english then
    ------- Guess i didnt need to reboot my lap ....anyway
    11.- Lets chk out:

    dmesg

    and i found this:

    ath_hal: module license 'Proprietary' taints kernel.
    ath_hal: 0.9.14.9 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413)
    wlan: 0.8.4.5 (EXPERIMENTAL)
    ath_rate_onoe: 1.0
    ath_pci: 0.9.4.12 (EXPERIMENTAL)
    PCI: Enabling device 0000:02:00.0 (0000 -> 0002)
    ACPI: PCI interrupt 0000:02:00.0[A] -> GSI 5 (level, low) -> IRQ 5
    ath0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
    ath0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
    ath0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
    ath0: turbo rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
    ath0: mac 5.9 phy 4.3 radio 3.6
    ath0: 802.11 address: 00:0L:6V:07:77:ep
    ath0: Use hw queue 0 for WME_AC_BE traffic
    ath0: Use hw queue 1 for WME_AC_BK traffic
    ath0: Use hw queue 2 for WME_AC_VI traffic
    ath0: Use hw queue 3 for WME_AC_VO traffic
    ath0: Atheros 5212: mem=0x20800000, irq=5

    #Note: Actually thats no my real log but its pretty much of what i get and #im not gonna type all that.

    12.- Then i use the Mandrake Control Center Tool>Hardware>Ethernet Card>AR5213 802.11a/b/g Atheros.

    - Configure Module.... then
    - Config tool ....

    13.- and .......... IM ON BUSSINES ........
    14.- ITS WORKING NOW ... BUT I DONT KNOW WHY .. I HAVE THE FEELING THAT I HAVE TO WORK A LITLE MORE TO IMPROVE ITS PERFORMANCE.
    15.- Thats pretty much what i did ... hope i didnt miss any detail.

    16.- I dont think that i qualify for writing here ... but this is helping me to feel much better than yesterday (lastnight i feel like an idiot ... i even dream about linux ... )

    17.- If uve got some linux info like ... TUTORIAL FOR BEGINNERS, pls send it to my email ... i will apreciate that.

    18.- LOS VERE EN EL MUNDO ... SALUDOS
    -----------




    Basically i used the first guide with some minor modifications.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •