Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
Hi, I have an IBM R51 laptop and am running mandrake linux 10.1 on it. Linux recoginises my wirless card as Vendor: ‎Atheros Communications Inc. Description: ‎AR5213 802.11a/b/g Wireless Adapter ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    39

    setting up wireless


    Hi,
    I have an IBM R51 laptop and am running mandrake linux 10.1 on it.
    Linux recoginises my wirless card as
    Vendor: ‎Atheros Communications Inc.
    Description: ‎AR5213 802.11a/b/g Wireless Adapter
    Media class: ‎NETWORK_ETHERNET

    But it asks me to load a driver manually to set it up. I tried several options. They didnt work.
    How do I find the right driver?
    Thanks.
    ligne

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    52
    Just an FYI,

    I have a Toshiba Satellite Pro with AR5001X mini PCI Wireless Adapter and have never been able to get it to work with MDK.

    The Only dist. I have tried that actually works so far is Mepis, which is what I now use for all my lappys.

    If yo get it working, post how here.

    Thanks.

  3. #3
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2005
    Posts
    19

    need help with atheros and MADWIFI

    i tried to compile the driver and got the following errors
    /usr/src/linux-2.4.27-0.pre2.1mdk/include/linux/smp.h:29: error: conflicting types for 'smp_send_reschedule'
    /usr/src/linux-2.4.27-0.pre2.1mdk/include/asm/smp.h:41: error: previous declaration of 'smp_send_reschedule' was here
    /usr/src/linux-2.4.27-0.pre2.1mdk/include/linux/smp.h:29: error: conflicting types for 'smp_send_reschedule'
    /usr/src/linux-2.4.27-0.pre2.1mdk/include/asm/smp.h:41: error: previous declaration of 'smp_send_reschedule' was here
    any ideas
    total n00b
    joex

  6. #5
    Linux User stokes's Avatar
    Join Date
    Oct 2004
    Location
    UK
    Posts
    274
    I had a nightmare getting my card to work in Mandrake (I was also a newbie while trying to work it out).

    My problem was I could see a wireless card inside mandrake control center but it was showing the wrong driver. I had to use ndiswrapper to install the windows driver for my card on Mandrake. My card is a LinkSys and they don't make drivers for Linux, so this was my only option.

    You might need to update your package sources first (on http://easyurpmi.zarb.org/) Then in a konsole type:

    Code:
    su root
    urpmi ndiswrapper
    Download the inf and sys files for your specific wlan card to your Linus computer (for example, in /var/src/devicedriver.inf)

    Code:
    ndiswrapper -i /var/src/devicedriver.inf
    modprobe ndiswrapper
    ndiswrapper -l
    This should load the driver into memory. The -l command will show you what's running. Then try:

    Code:
    iwconfig wlan0 up
    iwconfig
    ... and let us know what happens!

  7. #6
    Just Joined!
    Join Date
    Jul 2005
    Posts
    19

    Wifi Woes getting there sort of


    I've got KDE 3.3 up and most every package known to man but still no luck.
    I too have mcc seeing the card (atheros 5005gs) but loading the wrong driver (ath_pci).
    I tried to force the madwifi driver listed in MCC but that hasn't worked either. no luck yet.
    gonna try the nsdiwrapper approach.

  8. #7
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Quote Originally Posted by joex
    I too have mcc seeing the card (atheros 5005gs) but loading the wrong driver (ath_pci).
    Thats actually the correct driver for atheros based cards. the madwifi project makes drivers for a variety of cards, but in your case, the ath_pci driver is the correct one.

    what does iwconfig spit out? after you have told mandrake to use the ath_pci driver and have set up WEP, essid etc.

    See loft306's post on wireless cards under linux for more info.
    Life is complex, it has a real part and an imaginary part.

  9. #8
    Just Joined!
    Join Date
    Jul 2005
    Posts
    19
    iwconfig says
    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 no wireless extensions.

    sit0 no wireless extensions.

    but the device is seen in MCC and with lspci?!

    I can only find the .sys atheros driver. still looking for the ini. any ideas?
    [/code]

  10. #9
    Just Joined!
    Join Date
    Jul 2005
    Posts
    19

    SOLVED

    so here's what happened....
    Sometime in the upgrade....patching....urpmi....update process the 2.4.x.x.x version of the
    souce kernel were installed into /usr/src. It was installed with the appropriate symbolic links too. Apparently when I upgraded the kernel to 2.6 I did not get the souce files too!! Naturally when the Madwifi went to grab source to compile, it found 2.4 source and blew up.
    My soulution was as simple as
    root@machine uname -a to determine the PRECISE kernel version. In my case 2.6.8.1-12
    open mandrake update and search for that kernels' source mdk and install it. Mandrakes rmp manager intalled it to its default directory (/usr/src) and filled in the symbolic links.
    following root@machine:/home/user/madwifi/# modprobe ath_pciAt this moment, doc wiki for the madwifi driver all else went fine!
    Beware of a minor typo in the doc wiki written by Hugo Chasqueira. He states
    "root@machine:/home/user/madwifi/# modprobe ath_pciAt this moment, Mandrakelinux... "
    The space between ath_pci and the next part At this moment bit me once or twice but otherwise worked fine.
    Special thanks to J Redinger and AlexK for there tireless devotion to this little user masmanagement!
    joex Laughing Laughing Laughing Laughing Laughing Laughing Laughing Laughing Laughing Laughing
    _________________
    joex

  11. #10
    Just Joined!
    Join Date
    Jan 2005
    Posts
    39
    hi ,

    I did exactly what you say joex. but the modprobe command gives an error message.
    I believe I did exactly what you mentioned.
    ligne

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •