Find the answer to your Linux question:
Results 1 to 4 of 4
I have mounted my external USB hhd for my mandrake 10.1 OS. everything is ok, i can browsr,... but i couldnt have a write permission to it. what I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    8

    AluDisc External USB Harddisk


    I have mounted my external USB hhd for my mandrake 10.1 OS. everything is ok, i can browsr,... but i couldnt have a write permission to it.

    what I have done:
    in /etc/fstab: add the line --->/dev/sda /mnt/aludi auto noauto,users,rw 0 0
    then i tried changing the owner or permissions using chown & chmod... but failed!
    Could someone please help me getting the write permission

    tnx guys!

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    If your external drive is formatted as NTFS, sadly you cannot write to it at all, as it can damage the contents of the drive. However, if it is formatted as FAT or other, try one of the fstab entries below.


    Change fstab entry to something like:
    Code:
    /dev/sda1 /mnt/aludi auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,rw,exec,users 0 0
    or
    /dev/sda1 /mnt/aludi vfat umask=0,iocharset=iso8859-1,nls=iso8859-1,codepage=850,rw 0 0
    The extra stuff just force Mandrake to detect things correctly. The 1st option autmounts the drive, the 2nd one, you will have to type mount /mnt/aludi in the console.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    8

    tnx

    thanks for ur reply AlexK,

    I changed fstab as u said a little modified though, i.e. /dev/sda /mnt/aludi auto umask=0000,user,iocharset=iso8859-1,codepage=850,noauto,rw,exec,users 0 0

    the usb drive is mounted as rwxr-xr-x, but ,even as a root, i cant write to it, or change its permissions

    the error to the following command: chmod 0774 /mnt/aludi
    is
    chmod: changing permissions of `/mnt/aludi/': Read-only file system
    ....

    Any hint would be appreciated!
    thanks

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Ok, few errors in your typing i can see. Firstly it should be /dev/sda1, That is unless you have a SATA based internal hard drive, in which case, the sda1 would be replaced by sdb1. The 1 is required to tell the system which partition to mount.

    Using chmod on the folder won't make it writeable in this instance. The problem lies in the type of filesystem the disk uses. IF the disk uses a NTFS file system, currently it is very dangerous to write to a NTFS file system under linux. If it uses a FAT32\FAT16 file system, then it can be written to under linux.

    So in conclusion, you may not be able to write to the disk because the file system the disk uses is currently does not have write support in linux.
    Life is complex, it has a real part and an imaginary part.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •