I set up cups printing and installed printer. I sent test print and it says it sent is successfully but it says it's printing for as long as I leave it in the queue. In other words, it never prints. I give it about 15 minutes and then I finally remove it from the queue. This is a remote printer on my home network (windows/samba printer setup). The remote printer is an hp deskjet 990c on a windows xp workstation. Any help would be appreciated. Thank you. I am using mandrake 10.1. I have checked the share, and can even get to the xp box itself in a browser window and the corresponding shares via smb://. This doesn't show the printer in the browser window, though. I have run the smbclient -L command and it does list the printer share there, as well. I have tried connecting to thenetbios name and the ip address, I have tried other drivers, I have tried using other connections other than CUPS, I have used the control center and kde printer wizard. NOTHING WORKS! It sends the print and just sits there. In looking at the IPP report for the printer, I still get: Unable to connect to SAMBA host, will retry in 60 seconds...ERROR: Connection failed with error NT_STATUS_ACCESS_DENIED. The print just hangs in the queue. I was told to ensure the user account on the linux box and xp box match up (name and password, they do), and to set up the smbuser account. In looking for information on the smbuser account, I don't find much. I am at a complete loss at this point. I have installed the printer about 30 times, to no avail. Help? Please?