Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
I am new to Mandrake 10.1(official) but have a working knowledge of Kubuntu. My D-Link 650+ card works great in Kubuntu. I am trying to get my wireless card working ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Location
    Minnesota
    Posts
    25

    Wireless ACX100 (D-Link 650+)


    I am new to Mandrake 10.1(official) but have a working knowledge of Kubuntu. My D-Link 650+ card works great in Kubuntu.
    I am trying to get my wireless card working in Mandrake and need some help.
    /sbin/iwconfig detects nothing (no extensions), the GUI 'add connection' also did not detect my card even though I chose the ACX100 driver.
    In Kubuntu my settings are:

    mapping hotplug
    script grep
    map wlan0

    #primary network interface

    auto wlan0
    iface wlan0 inet dhcp
    wireless_essid D-Link
    wireless_channel 6
    wireless_mode managed

    What is the equal (config file) in Mandrake? Where do I start?
    thanks in advance.

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Have you tried following the instructions found here?

    I also had some trouble getting my ACX111 card working under MDK 10.1 and native drivers, the way I solved this problem was to use ndiswrapper.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Location
    Minnesota
    Posts
    25

    build environment questions

    I got stuck at this point.
    ls /lib/modules/`uname -r`/build/include/linux/version.h

    I am using Mandrake 10.1 (official)

    seems I have no build directory?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    ok, does /lib/modules directory contain a folder called 2.6.8.xx or something similar? if it doesn't you will need to install the kernel sources. To do this, go to the MCC, select software and then add software. In the list which comes up, tell it to search for "kernel-sources", install this. If it cannot be found in that list, you will have to download it via either urpmi or through the online update tool.

    Usually, the kernel source files are included on the installation media, and these are required for the insertation of the acx driver into the kernel. it would be preerably if the installation media contained the kernel source as it would match your current kernel version, whereas a download may not match your kernel version.
    Life is complex, it has a real part and an imaginary part.

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Location
    Minnesota
    Posts
    25

    wireless working, needs to come up automatically

    I followed these instructions to create a file called 'local' that has my wireless card driver info:

    If init.d exists, then type: echo -e '\n#!/bin/sh\n#Bring acx100 device up\ncd /home/your_normal_username/acx100-0.2.0pre8_plus_fixes_51/scripts\n./start_net\n' > /etc/init.d/local to create an rc.local-like file that will bring your device up on bootup. Be sure to substitute your "normal" username in the appropriate place in that command. Then, make the newly-created file executable with: chmod +x /etc/init.d/local. One more step is required to get your newly created "local" file into the startup system, type: update-rc.d local defaults 99.


    update-rc.d local defaults 99 command does not work, I get the error, "bash: update-rc.d: command not found"
    what or where is the update command?
    --------------------------
    OK I figured it out it was a typo by the author, the command should have been:
    update rc.d local defaults 99
    but my script is still not being loaded at boot, the system still trys to go to eth0 and eth1 and then when it gets to wlan0 it skips it?
    How to get the first choice to be wlan0 and load the driver?
    Thanks!

  7. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    have you tried Craig's instructions for MDK 10.1

    Quote Originally Posted by http://www.houseofcraig.net/acx100_howto.php
    Mandrake 10.1

    1. You MUST remove the Mandrake 10.1-supplied very old version of the acx driver, since it's so old that it never even heard of an acx111 or acx100 USB device! (it's an 0.2.0pre7_plus_fixes_3 or earlier version, and we're now up to 0.2.0pre8_plus_fixes_51 if that gives you any idea how old the Mandrake module is)
    2. It's located here: /lib/modules/`uname -r`/kernel/3rdparty/acx100/acx100_pci.ko.gz
    3. Type this: rm /lib/modules/`uname -r`/kernel/3rdparty/acx100/acx100.ko.gz to delete it (it's really not worth saving, so delete it.)
    4. Then, type this: ln -s /lib/modules/`uname -r`/net/acx_pci.ko /lib/modules/`uname -r`/kernel/3rdparty/acx100/acx100_pci.ko.gz to create a symlink to the "old" module name that will work with (fool?) Mandrake 10.1's drakconnect utility
    5. Then, get the card up and running using the start_net script, or by feeding commands via ifconfig/iwconfig/route at the shell(Konsole), don't fail to do this first.
    6. Now, you can go to the Mandrake Control Center and the "Manage Connections" option to configure your acx device.
    If you look at step 6, try configuring the device from the MCC. Select Wireless connection, give it the name of the driver, tell it the ESSID, wep key etc. and you should be fine.
    Life is complex, it has a real part and an imaginary part.

  8. #7
    Just Joined!
    Join Date
    Mar 2005
    Location
    Minnesota
    Posts
    25

    not present

    Yes I followed his instructions...everything works great except I have to start the card from the terminal, it does not start at boot time.
    I get a message that it can' find wlan0 (that's because the driver is not loaded) and it's delaying start of the network. I then start the card from the terminal and everything is fine. Once the card is started I go to MDK control center and configure it there but on reboot the results are the same?
    Any ideas?
    Thank you--

  9. #8
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Have you added the module to /etc/modprobe.preload? If you haven't, you should so that the module will load at boot. That may fix your problem with your config not "sticking", as well. I've had Mandrake/Mandriva lose settings for cards at boot when their modules aren't loaded.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  10. #9
    Just Joined!
    Join Date
    Mar 2005
    Location
    Minnesota
    Posts
    25
    OK, that might work but what exacly gets added to this file.
    There is a file: init.d/local that runs the script to load the driver, would that be it?

    Thanks!

  11. #10
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    You would add the name of the module to the file.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •