Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 23
Hi nalg0rath, I would like to let you know that I have made considerable progress. I manage to find out from the stage1 log in the / directory that my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12

    Hi nalg0rath,

    I would like to let you know that I have made considerable progress.

    I manage to find out from the stage1 log in the / directory that my IDE device is in fact /dev/hda, I believe this is because it is associated with the window OS in drive0.

    OK, gone through the instruction you provided, with a bit of learning curve on my side, everything work perfectly. Mounted my DVD drive to /mnt/cdrom, run the file, NVIDIA licencing agreement come up, I said: I have got it !!!!

    Then It tried to match the Kernel and it said it could not find the required Kernel, What a BUMER !!!! First: It is the drive !!! Now it is the bloody Kernel !!!! SO the Kernel that come with the DVD in the LINUX FORMAT magazine June 2005 issue does not work with this driver.

    It suggest that I go to the FTP Nvidia download to look for the Kernel. I would do that next. Once I down load the damn thing if I can find it. The next challenge is to update my Mandrivia.

    How do I update Mandrivia with the latest Kernel once I download it !? (assume I can find it !!)

    In anycase, I thankyou for the all the help you have provided so far, much appreciated. I certainly learn a few thing from this.

  2. #12
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    All you have to do to download the desired driver is to run:
    Code:
    # yum install kernel-devel
    This requires a internet connection ofcourse. There should be a kernel-soure or a kernel-devel package on the CD you installed from. Just mount the CD and browse around a bit or search it for the kernel-source or the kernel-devel package.

    When you have done that you have to enter compile the kernel by doing:
    Code:
    # cd /usr/src/linux
    # cp /boot/config-[YYY] /usr/src/linux/.config
    # make
    Where [YYY] should be replaced by the version number of the kernel that you currently use.
    Just
    Code:
    ls /boot/
    to find what the full name is.

    Hopefully it will work to run the nVidia installer now. If it doesn't you'll have to install the kernel by issuing:
    Code:
    # make modules_install
    # cp arch/i386/boot/bzImage /boot/vmlinuz-[VERSION]
    # cp System.map /boot/System.map-[VERSION]
    # cp .config /boot/config-[VERSION]
    Where you replace [VERSION] with the version of the kernel that you just installed from the kernel-devel or kernel-source. This version can be found in the package description and often you can do:
    Code:
    ls -l /usr/src
    and see what version number it is linked to.

    After you have copied the files with "cp" you'll have to configure you boot-loader to boot your new kernel.
    Depending on what boot-loader you use you have to do it a bit different.

    Using LILO:
    Edit your /etc/lilo.conf and copy the existing section and just change the names so that they point to the files that you cp'd. (Make sure to keep the old section).
    When you're done editing you run:
    Code:
    /sbin/lilo
    Using GRUB:
    Edit your /boot/grub/menu.lst in the same whay as I described with LILO and make sure to keep the old section.
    When you're done editing, run:
    Code:
    grub-install
    When you have edited your boot-loader yo have to reboot your computer and select the new item in the boot-loader menu. If it boots fine you can try running the nVidia installer again.

    If you run into any problems keep posting and I'll try to help you.

  3. #13
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    207
    I do not want to criticize nalg0rath's good advice, but two simple remarks follow :

    - for mandriva, the package installation command is not yum, it is urpmi. So run "urpmi" instead of "yum". That command has to be ran as root, btw. To log as root, in console mode, type "su" (for Super User), followed when asked by the root password. To quit root mode in the console, type "exit" (in root mode, you have all the rights, including the capability do do things that will destroy your sytem, so be sure to be logged as root only when necessary, Bluemoon.)

    - OK, all that process might work, but have you considered trying to format your nux partitions and then trying to reinstall your mandriva afresh, again, with the hope that everything will be fine this time ?
    Mandriva 2005 LE is the most recent mandrake-mandriva distro available, and having that kind of bug seems strange to me, I thought that could only happen years ago. Besides nvidia display drivers AND nvidia acceleration drivers are natively installed on 2005 LE, and should natively run without the slightest problem.
    That's why I wonder if you didn't check by accident the wrong options, whatever they may be, during the installation. If you do another installation, keep the default settings, though make sure to have KDE installed, to check to start automatically logged and in a graphical interface. You'll come to a point where are listed all the things to install and will have to click a button to configure each of them. Clicking to configure network, sound, graphics. Chose graphics, chose nvidia, chose your monitor from the list (or take a generic one), check the other options.
    Finish install, see if it works, i'd suggest.
    If you still have exactly the same bug, you'll know that you have indeed a problem, and all you'll have to do again, to resume your previous state of the problem, is to do the mounting thingie.

    - Third remark, unrelated to the previous remarks : if you have had network configuration done in your mandriva install, there's a text editor much more simple than vim, it's called "nano". It REALLY is more easy to use ^^
    To install it, when logged as root, if your internet connexion works, just run "urpmi nano", and it will download and install the program, it's a very small thing to download.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Quote Originally Posted by sabin
    To log as root, in console mode, type "su" (for Super User), followed when asked by the root password.
    su doesn't mean "Super User", it means "Substitute User"
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  6. #15
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    207
    Even the doc (man su) tells me that it means Super User o_O
    Well, unless you write "su --login ...", I feel that the single command "su" would better mean super user, whatever "true" definition might require ^^
    Thanks for the wikipedia link about su, i'll sleep less stupid tonight :o

  7. #16
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    Quote Originally Posted by sabin
    ...
    - for mandriva, the package installation command is not yum, it is urpmi.
    ...
    Yeah, thats right... I haven't used Mandrake (now Mandriva) for years so I don't remember everything distro-specific, but thatnks for correcting me.

  8. #17
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    OK, now I am on the verge of giving up ......

    Let me get back one step and try to outline exactly what I have done , perhaps then your guy can tell me I should I do next or where did I go wrong.

    1. When I tried to installed the file NVIDIA-linux-x86-1.0-7667-pkg1, the message I get is: No precompiled kernel interface was found to match your kernel. Then it ask if I want to do a download from ftp://downlow.nvidia.com, as I do not have internet connection via Linux OS, so this can't be done.

    But exactly what file is being asked to be download anyway, can someone explain !?

    -Then it suggest to re-compile the kernel, but fail. Error message is shown: Unable to find the kernel source tree for the currently running kernel, please make sure you have installed the kernel source files for your kernel;

    Nalg0rath,
    I tried to follow your code but have little suscess, it would appear I used either the wrong extension or the path specified is iccorect...

    # cd /usr/src/linux
    # cp /boot/config-[YYY] /usr/src/linux/.config
    # make

    There is no linux folder in /usr/src/ ...... Should I generate one !?
    But in the /boot dir, I can find 3 kernel files as listed below:
    Kernel.h-2.6.11;
    Kernel.h-2.6.11-6mdk;
    Kernel.h-2.6.11-6mdk-i586-up-1GB;

    So what is [YYY] base on the above !?
    What should I do next :Q

  9. #18
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    207
    Try the reinstallation process, Bluemoon. Look, that whole mess takes you tens and tens of minutes, right ? A reinstall attempt won't take more than ten more minutes, and maybe that will work.

    IMO, the precise package you miss is kernel-devel. You see, the nvidia driver, I think, adds stuff to the kernel, so the kernel, I suppose, has to be recompiled. And to recompile a kernel, you need kernel-devel package. But without an internet connexion, try the reinstallation. You don't even have to format first, after all, if you don't want to.

  10. #19
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    Sabin,

    I appreciate what you are saying about re-installing, that was the first thing I thought of. Infact, I have re-installed the damn thing at least 20 times, what !? 20 times !? YES, at least 20 times !!!! everytime, I picked different X server, but the result is the same. The problem is with the display, and it is well documented. The new driver from Nvidia is supposed to fix these bug. Sometime I use the Xorg X server as a back up, and every time it is broken, BROKEN !? yes, broken. that is the message I got from the installer.

    OK, Thanks to clarify about kernel-devel, so there is indeed an other process that is required. Would it be possible that I download this device from window enviroment, save it to a disk and , boot into linux, mount the CDROM and run it !? I have to say the Mandrivia installer is quite user friendly. It is just unfortunate that I have a card which is not compatible.

    Thanks guys. I do appreciate your help.

  11. #20
    Just Joined!
    Join Date
    Jul 2005
    Location
    Lancaster, SC
    Posts
    4
    Quote Originally Posted by Bluemoon123
    OK, now I am on the verge of giving up ......
    I'm with you 'Bluemoon123' ! That's how I found this site..... I was searching for a solution and your post popped up... I'm a newbie but I have tried everything I could think of, including reinstalling! As a matter of fact I just loaded LE2005 because I thought my kernel was old and I'm not very good at recompiling the kernel. It's easier for me to reinstall

    I was getting the same error you have until I loaded LE2005. Now it trys to build the kernel interface but it fails “Unable to load module 'nvidia.ko' “

    I still get the “No precomplied kernel interface” error.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •