Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
Hi all, I am newbie on Linux, after some effort (to me anyway )I manage to install the Mandrivia LE 2005, as I am setting up a duel boot system, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12

    Display problem with Nvidia card Quadro FX540.


    Hi all,

    I am newbie on Linux, after some effort (to me anyway )I manage to install the Mandrivia LE 2005, as I am setting up a duel boot system, I have been using LILO as my boot loader, there is no problem in booting to either window or Linux. Except in Linux, at the end of all the checks (all status are OK) and just about the GUI is being loaded, the whole screen went blank, while the mouse is still working. nothing is displaced, it just hanged !!!

    During the installation, as I could not see the FX540 being listed, so I just picked Nvidia generic hoping in hell that all thing will work !!! Unfortutunately Not !!!!

    I have since download the latest driver from Nvidia, the file is: Nvidia-linux-x86-1.0-7667-pkg1, since I have not set up linux application yet, this was down load in window, I have copied this file to a CD.

    I can boot to the Linux console OK, but this is as far as I can go......
    How do I go from here !!?? ,

    i.e

    How do I copy this file from the CD to a directory !?
    Which directory do I copy to ? Do I need to delete some existing file ?
    What existing configuration file I need to change & how to do it ?

    My knowlege on the command console is minimal.
    Any help & comment is much appreciated.

    Thanks

  2. #2
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    207
    If you can chose to start in text mode, you can chose to install the nvidia driver.

    Though we can't tell you the commands from memory, don't worry, there is a readme file provided with the nvidia driver :


    http://www.nvidia.com/object/linux_d..._1.0-7667.html
    For the single command you'll use to run the install of the driver.

    ftp://download.nvidia.com/XFree86/Li...667/README.txt
    For detailed instructions : you will need to edit one of your files afterwards, that will require reading this.
    To edit your x config file, use msdos-like navigation commands "cd.. cd foldername", and then you can use a console-mode text editor like vi (vi nameofthefileyouwanttoedit), even though at first time you use it will be a nightmare, i'm afraid.

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    Hello Sabin,
    It seems the readme link in the Nvidia site is a dead link.
    I have tried that before I post my initial message. Do you know of any other link !? Thanks

  4. #4
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    To be able to access the file(s) on your CD you have to mount it. To mount it you have to know what device it is (/dev/[xxx]). There is often a symlink between /dev/cdrom and your device so you could try to use /dev/cdrom in the following command:
    Code:
    # mount /dev/[xxx] /mnt/cdrom
    Just change [xxx] to the cdrom device. Remember to make sure that the mountpoint /mnt/cdrom exists before mounting. When you have mounted your cdrom you can copy over the Nvidia-linux-x86-1.0-7667-pkg1.run file to your home directory and then run it with these commands:
    Code:
    # cp /mnt/cdrom/Nvidia-linux-x86-1.0-7667-pkg1.run ~/
    # ~/Nvidia-linux-x86-1.0-7667-pkg1.run
    optionally run it directly from the mounted CD:
    Code:
    /mnt/cdrom/Nvidia-linux-x86-1.0-7667-pkg1.run
    In both cases you'll have to change /mnt/cdrom to the mountpoint you used when you mounted the CD.

    You dont have to delete any existing file, but you have to edit your /etc/X11/xorg.conf
    To edit the file you have to use a text editor, for example:
    Code:
    vim /etc/X11/xorg.conf
    This will open the file in vim. Vim is quite confusing if you're a beginner, so if you have any installed you could use a simpler text editor such as pico or nano.

    When you have opened up your text editor you have to find a line that looks like this:
    Code:
          Driver "nv"
    and remove the "nv"-part and replace it with "nvidia", so it should look like:
    Code:
          Driver "nvidia"
    After that you have to edit another part of the /etc/X11/xorg.conf. Find the "Modules" section and remove the following lines if they're present.
    Code:
        Load "dri"
        Load "GLCore"
    Then add a new line in the "Modules" section (if it's not already there):
    Code:
        Load "glx"
    Save the file and reebot your computer in graphics mode or start X from command line by running:
    Code:
    startx

  5. #5
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    Thanks nalg)rath
    I will try to follow your instruction & will keep all posted with progress.

  6. #6
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    207
    I post this just in case, I have already noticed that, in my case, instead of "load glx", for my GeForceIV, it says :
    Load "/usr/X11R6/lib/modules/extensions/libglx.so"
    It works fine for me, so if "load glx" fails, you could try that ;o)

    Besides, Bluemoon, I tested again and the readme.txt link works fine o_O
    Perhaps you need to first open the html page, after which you could open the readme... o_O

  7. #7
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    OK, I think i better clarify everything before I make another attempt at this, All these booting in & booting out really drive me nut.

    First stupid question I have:
    How do I find out what device it is !? i.e this XXX agurment. As indicated by nalg0rath.........
    It is a port no !? or what !?

    I think your guy may need to bear with me, you can safely assume my knowlege on linux is nough, a big bloody nough !!! the 2 cmds i know are cd & ls, that is it. No i know pwd as well.

    So without knowing what XXX, i can't proceed much further.

    What I have done so far is login /root, do a ls and found drakx/ & tmp/.
    did a cd .. and see some dir, went into mnt/ and see cdrom/, so cdrom/ does exist.

    I have not make any changes yet as suggested by nalg0rath until I find out what XXX is.

    I did try a startx just for the heck of it and see what happen , this is what I get.

    execue fail for /etc/xxx/x (errno 2)
    giving up
    xinit: connection refused (errno 111): unable to connect to X server.
    xinit: no such process(errno 3): server error.

    Which seem to confirm the problem is with the X server.

    I really want to get this sucker working with your help, I do not expect to have everything serve to me on a plate, but any hints and help would be much appreciated.

    Thanks

  8. #8
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    Ok, this variates between distros and systems:
    Replace "[xxx]" with "cdrom" and try, this usually works but not always.

    If you're using IDE/ATAPI:
    If you have one harddrive and one cdrom you should probably replace "[xxx]" with "hdb".
    If you have two harddrives and one cdrom you usually replace "[xxx]" with "hdc".

    Others:
    replace
    "[xxx]" with "sca"
    "[xxx]" with "scb"

    Edit: If you still cant find it post your the output of "dmesg"

  9. #9
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    Thx nalg0rath, I do appreciate your help. I installed ed, gedit and vim during the setup. I am doing a google search on how these editor work.
    everything is starting from basic for me !!!
    One thing i noticed during the status check at boot up is i am in run level 3. So i suppose I am in the correct level !?

    My system is 2 hd system with the DVD/CD writable drive.
    so hdc will be my first try.

    my probing around revealed the xorg.conf is actually in / dirctory.
    I seem can't find xorg.conf in /etc, I can't even find /X11 in /etc.
    But I look more carefully this time ......

    Also when I tried to open xong.conf in /, there seem to be nothing in the file anyway, I think I just have keep at it and tryout everything.

  10. #10
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    Runlevel 3 is good so far, you might want to change it later when yo've installed the drivers to make the computer boot into a graphical login.
    Are you sure that there isn't a /etc/X11 -directory? remember that linux is based on unix and therefore case sensitive.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •