Find the answer to your Linux question:
Results 1 to 10 of 10
Alright, I just installed Mandrake, and I must say I love it! It seems to run so much better than Ubuntu - Kubuntu. Anyways, I have some software installed that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    15

    Software Installation


    Alright, I just installed Mandrake, and I must say I love it! It seems to run so much better than Ubuntu - Kubuntu. Anyways, I have some software installed that comes default, but I have no clue as of how to install new applications such as XChat. I think you are suppose to download the Mandriva RPM from their website. So I did that, but I'm not sure what command to type in a terminal to set this beast up. Also, my other problem is that in order to boot into either Windows or Mandriva I have to first boot into my BIOS and disable APIC- MODE and then reboot into Windows. If I want to use Mandriva I have to go back and set the APIC -MODE back to off. I know this is'nt the way things are suppose to be. Is there an easier way than having to recompile a Kernel or is that my only option.

    PS: Man I miss apt-get install

  2. #2
    Linux Newbie
    Join Date
    Jan 2005
    Location
    India
    Posts
    110
    as you have apt-get for Kubuntu.you have got urpm for Mandrake search it on google you will get information about it easily and how to set it.

  3. #3
    Linux User
    Join Date
    Mar 2005
    Location
    CA
    Posts
    352
    For you first problem, installing Xchat you can use the rpm command:

    Code:
    rpm -ivh *.rpm
    As tarun said, you can look into urpmi, which works like apt-get, but for Mandriva: http://easyurpmi.zarb.org/ And be sure to check out Thac's repositories after you get urpmi installed: http://rpm.nyvalls.se/graphics10.1.html

    Hope this helps you out.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2005
    Posts
    15
    OK, I tried those links, sorry but what am I doing wrong. I get this error every time I try and add media and or install using URPMI -- bash: urpmi.addmedia: command not found

  6. #5
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    the urpmi command only works for root. become root in the terminal and then try using the urpmi add media command.

    depending on the bootloader you are using, you can turn on or off the apic mode. If you are using lilo, edit the /etc/lilo.conf file as root and add the no_apic option to the default linux entry. the correct parameter (either it is no_apic or apic=off) can be found in the entry for failsafe in the lilo.conf file.

    However, if you are using grub, you will need to add the noapic option to the /boot/grub/menu.lst file. This way you won't have to keep entering the bios to turn on and off the apic setting, now you can just leave it on.
    Life is complex, it has a real part and an imaginary part.

  7. #6
    Linux Newbie
    Join Date
    Jan 2005
    Location
    India
    Posts
    110
    watzz try the urpmi commands being root and also see that u have setted the proxy setting in the update manager if u are using a proxy server.
    hope this helps

  8. #7
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Have a look at this tutorial: http://www.linuxforums.org/tutorials...ial-19957.html, since it covers installing with both rpm as well as mandrakes urpm system
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  9. #8
    Just Joined!
    Join Date
    Jun 2005
    Posts
    15
    Great ! I installed XChat, but now I am on to bigger and better. Is there a list of packages that you can use URPMI with ? I tried to install java using urpmi j2re, and I also used urpmi java, which gave me an option to install, but I dont think it was what I was looking for. So both were unsuccessful.

  10. #9
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    Because of licensing issues, you probably have to download the .bin from the Java sun site and place it in a specific directory, then use the RPM, otherwise, just visit the java sun site and download their linux installer

    (if you downloaded the .bin into /home/qub333/)
    chmod a+x /home/qub333/javafilename.bin
    ./javafilename.bin

    and follow the onscreen instructions. Also, try man urpmi so see if you can search the urpmi repositories, sometimes packages have really odd names.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  11. #10
    Just Joined!
    Join Date
    Jun 2005
    Posts
    15
    OK, got that done. Now Im on to limewire. I install it fine using urpmi. When i go to launch it via terminal because it doesnt show up in my applications list tab. I get this message
    /usr/bin/limewire: error: failed to set JAVACMD
    /usr/share/java-utils/java-functions: line 135: -mx32m: command not found
    Do i need to install via RPM..or can it just be a simple edit in some file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •