Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all, i recently installed from a linux magazine the Mandriva LE 2005 (10.2) linux DVD (on a dual boot HD with windows 2000). Everything went OK, with a slight ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    4

    Problem with Mandriva 10.2 and External 56k modem


    Hi all,

    i recently installed from a linux magazine the Mandriva LE 2005 (10.2) linux DVD (on a dual boot HD with windows 2000). Everything went OK, with a slight exception:

    Linux doesn't recognize my external 56k modem (an old USRobotics Sporster Flash, non software base, plugged to the serial port) automatically, so i was able to run through the manual installation, and could even set it to actually hear it make the phone call to my ISP, and even get an IP address from him...

    Problem is (i suppose) with DNS resolving. I am unable to nagivate the internet, and my pings give me the unable to resolv error. Also, when i ask the DrakConf configuration tool to test my internet connection (and hear my modem doing the phone call) it complains after a while that it seems no connection has been established.

    I suppose there might happen two different problems:

    -either linux is not capable of identifying myself correctly using CHAP (in windows, i use MD5 CHAP for authentification, is that the same as the CHAP option in linux?)

    -or i have a problem with DNS resolving : i have entered the IP addresses i use (without problems) in windows 2000, but i seem unable to resolv names into IPs...

    Any help would be much appreciated,

    Thank you very much,

    Guillem.
    (Spain).

  2. #2
    Just Joined!
    Join Date
    Aug 2005
    Posts
    2

    The same problem!

    Hi,

    The very same problem, the very same modem.

    Have you solved the problem already?

    My observations of modem bahaviour are basically the same as above.

    One thing that I noticed:
    In the log you can find that the configuration of modem is not acknowledged (by ISP modem) properly.
    In this case I don't even know where to start.

    Well, I keep searching.

    Biggero

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    4

    not solved yet

    Hi biggero,

    i'm sorry to say i haven't solved it yet, i've been on holidays off home in the while, and now that i'm back don't have much time for trying to solve it.

    Anyway i have been able to check that the problem hasn't go to do with ISP authentication, i've set the system to log pppd messages and the authentication proceeds OK. So my problem must be related to DNS (even though i don't have a clue of why isn't working after setting the right IP addresses for DNS servers (?)).

    If i find the way i'll post it here, good luck with your search too !

    Guillem.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2005
    Posts
    2
    Hello,

    I finally got my DSL connection to Internet. After three years of applying it showed that the line was ready for DSL from the very beginning but telephony company could not find it out.
    Well, that is how the things are in Poland.
    Anyway I don't have to use the modem anymore.
    I have installed DSL under Mandriva (it couldn't be simplier by the way) and to my suprise it showed that I cannot get my Internet working the same way as it was with modem.
    And finally I knew. The firewall was the cause. In Mandriva it is called Shorewall.
    So it has to be adjusted to allow all the outgoing network traffic.
    The easiest method to check is to switch it off completely for a while.
    Nothing wrong should happen, but you should be careful anyway.
    Of course afterwards if has to be switched back on.
    Hope this will help.

    Biggero

  6. #5
    Just Joined!
    Join Date
    Sep 2005
    Posts
    6

    firewall :)

    Some guys helped me different modem same problem... firewall is configured to allow ethernet connections, not dial up...

    Network unreachable because of wrong firewall settings
    A firewall is automatically installed using eth0 instead of your interface to internet. To get back your internet access in the meantine, you can
    either use MCC / Security / Firewall then OK and change the network interface to ppp+
    or you can disable temporarily the firewall with this command after boot : "service shorewall stop"
    or for advanced users edit /etc/shorewall/interfaces and replace the line "net eth0 detect" with "net ppp+ detect" then service shorewall restart.
    this is necessary for all users connecting with a modem (analogic or DSL with pppoa or pppoe) or users connecting with another interface than eth0
    A fix will be available in drakxtools updates. Once you've installed the updates, you have to reconfigure your firewall with the firewall tool from the Mandriva Linux Control Center (drakfirewall).

    hope the above helps

    Ryan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •