Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all ! I installed Mandriva LE 2005 a few weeks ago, and i've been struggling since then with this problem: -I can't resolve IP into names, not when trying ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    4

    DNS not working


    Hi all !

    I installed Mandriva LE 2005 a few weeks ago, and i've been struggling since then with this problem:

    -I can't resolve IP into names, not when trying to surf the web with Mozilla FireFox, nor when pinging other outside.

    Here's some background on what i've been successful at:

    -I've been able to configure my external serial model OK.

    -I'm able to set up an internet connection using it, as i can see both my IP and my ISP's one with: ifconfig ppp0

    -I've entered the DNS IP addresses on /etc/resolv.conf file, and also made sure that there's a copy of resolv.conf in /var/run/ppp/ folder, as i detected a broken soft link pointing to it from /etc/ppp/ folder. In fact, Mandrake graphical configuration tool displays both DNS addresses.

    -There are only two entries when looking route table with route -n:

    Dest Gw GenMask Flags Metric Ref Use Iface
    ISP-IP 0.0.0.0 255.255.255.255 UH 50 0 0 ppp0
    0.0.0.0 ISP-IP 0.0.0.0 UG 50 0 0 ppp0

    If i try to modify route table by first doing:
    route del default gw

    and then adding my ISP-IP (which i can see from ifconfig ppp0) with:
    route add default gw ISP-IP ppp0

    i get the error:
    ppp0: host name lookup failure

    -I've looked at /etc/sysconfig/network, and i only have there two entried for my machine host name (but no GATEWAY= nor GATEWAYDEV= entries...after all, the IP for GATEWAY is dinamic IP, and it shouldn't be there until ppp0 is established).



    Any help would be appreciated, i'm clueless on what to do next...

    Thank you very much

    Guillem.

  2. #2
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    207
    I know that my reply won't sound much leet at all, that replying with code lines is cooler, but have you tried using Mandrake Control Center's assistant ? (Network and Internet > Configure
    a new internet connexion.)
    That assistant might automatically configure something that you had forgotten yourself ?

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    4
    Sorry, i forgot to tell that i first tried to configure everything through Mandrake Control Center, and it went fine up to establishing (and correct authentication) a PPP connection.

    From then on, no DNS name resolution, even though the right DNS IP numbers are displayed in Mandrake Control Center for that connection. That's when i started trying to fix it, and got stuck after my initial post tryings.

    Thanks anyway, any more ideas?

    Thanks !!

    Guillem.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •