Find the answer to your Linux question:
Results 1 to 3 of 3
hello all !! I am facing problem in booting my linux.The problem is as below: I have installed mandrake 9.1 with kernel 2.4.21.It was working perfectly afer intallation. suddenly one ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    2

    linux boot problem


    hello all !!

    I am facing problem in booting my linux.The problem is as below:

    I have installed mandrake 9.1 with kernel 2.4.21.It was working perfectly afer intallation.

    suddenly one day ,i got following error message when i booted it:

    mount error 6:mounting ext3 flags.
    mounted devfs on /dev
    kernel panic message:No init found Try passing init= option to the kernel.

  2. #2
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    138
    get a live cd ............. mount the hard drive and see where init is located........maybe you deleted it be mistake or the boot file is pointing to the wrong location..........if you find everything normal............then try to fsck your hard drive

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    2
    hi!!

    My init binay is at the place it should be :/sbin/init.

    but the problem is that it was working properly without any errors before.

    I have tried running fsck on all the partitions.
    It reported certain bad inodes and fixed them.
    but somehow,still it gives me the same error :shock:


    Is there any solution beyond running fsck?

    Any help in this direction is appreciated.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •