Find the answer to your Linux question:
Results 1 to 8 of 8
Hey guys, I have a problem with the KDE autologin, but when the system boots I can't use the graphic interface to shutdown the KDE autologin. Could someone please give ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3

    Need to shut down KDE Autologin


    Hey guys,
    I have a problem with the KDE autologin, but when the system boots I can't use the graphic interface to shutdown the KDE autologin. Could someone please give me the command line prompt or point me somewhere where I can find information on shutting down KDE autologin via command prompt.

    I am using :
    Mandrakelinux 10.1 PowerPack+
    Using KDE Desktop (don't know which version yet)
    AMD Athalon 1GHz
    1,500MB RAM
    ATI Sapphire 32MB
    Sony SDM-HX93 monitor

  2. #2
    Banned
    Join Date
    Aug 2005
    Location
    Sacramento, CA
    Posts
    112
    When your computer autologs in, click on the "K Menu" in the left hand corner. Click on "Control Center". Click on "System Administration". Click on "Login Manager". Go into the "Convenience" tab and click "Administrator Mode". After you enter the root password, uncheck "Enable Auto-Login". Click "OK". That *should* solve your problem.

    I hope that helps.

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    Okay I 'm sorry if the sentence "but when the system boots I can't use the graphic interface" didn't explain that "I cannot use the graphical interface". What I need is a way to shut down the auto login via command prompt, instead of using the graphical interface "that I cannot use".

    I hope that this explains my situation a little better.

    I appreciate your responce, but I have at this time no way to use the desktop, or any graphical interface until I can shutdown the autologin.

    Thank you.
    Lobos34[/b]

  4. #4
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    I am not that familiar with Mandriva but on the Mandriva forum I found that if you do "drakconf" at the command line that should bring up the Control Center.
    It will probably be ncurses based and you will have to navigate with the Arrow/Tab keys.

    What is the problem you are having that you need to turn off the Autologin?
    Why can't you get into X?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  5. #5
    Banned
    Join Date
    Aug 2005
    Location
    Sacramento, CA
    Posts
    112
    Oh sorry I didn't read carefully enough. I was working on something else at the time and was distracted. I think a command for getting a graphical system is
    Code:
    startx
    but it may not work. You should try what budman7 said about
    Code:
    drakconf
    .

  6. #6
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    Hey Guys,

    Thanks for the help, the drakconf worked perfect. There is a problem with the KDE autolog. It freezes on the user login and does not load the Desktop, but if I use startx on boot, instead of KDE autolog it works fine.


    Anyway Thanks again...

    Lobos34
    we will be known by the tracks we leave behind...

  7. #7
    Banned
    Join Date
    Aug 2005
    Location
    Sacramento, CA
    Posts
    112
    Glad we can help you out.

  8. #8
    Just Joined!
    Join Date
    Aug 2008
    Location
    Moscow, Russia
    Posts
    1
    If you are using a package named 'autologin' to autologin to your session, you can edit 'etc/sysconfig/autologin', in which you must set an option AUTOLOGIN from "...=yes" to "...=no" to disable autologin.

    Ouff. From Russia with love.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •