Find the answer to your Linux question:
Results 1 to 6 of 6
i have a 15" LCD monitor. when im running windows XP and use this monitor, 1024x768 is the highest screen resolution winXP will alow me to use. today i finally ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    6

    I can't see my gui...screen res too high. help me!


    i have a 15" LCD monitor. when im running windows XP and use this monitor, 1024x768 is the highest screen resolution winXP will alow me to use.

    today i finally got mandriva 2005 LE to install and as i was poking around and trying to teach myself how to do common tasks. i changed my screen resolution to one 'notch' higher than 1024x768. now when i load mandriva my monitor says "out of range" and won't display anything....so im assuming that 1024x768 is the highest screen res the monitor allows.

    my problem is, how can i change my resolution back if i can't see ANY of the gui?!

  2. #2
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    You can run xfdrake from the command line...or you can manually edit you xorg.conf file from the command line using VI if you want to go that route. It will involve you putting in the screen resolution by hand into the config file, through an excellent but quirky-if-you-haven't-used-it editor. Try xfdrake for starters. If it's a case that the display is on but your monitor shows nothing you can try booting into failsafe from your boot menu which should bring you to command line.

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    6
    booting in failsafe mode was the first thing i tried, and it did bring me to the command line. the only problem is i wasn't sure of what to do @ the command line. so xfdrake will help me out?

  4. #4
    Just Joined!
    Join Date
    Aug 2005
    Posts
    6
    so i typed in 'xfdrake' at the command line and nothing good happened. it gave me an error message but i forgot to write it down (DOH).

    i tried using VI....but i have no idea how to open files or edit them!

    im a complete linux newbie

  5. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    command line... then you'll need to su to root for this to work:

    su
    password (for root)

    use any text editor you have on your box, such as nano, vi, vim, joe, pico, or other, to edit the xorg.conf file like shown below:

    nano -w /etc/X11/xorg.conf

    now edit this file to use the settings you want

    save file, restart X

    note that some of the editors such as vi and vim can be tricky for new users

    hope this helps

  6. #6
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    here's more info for you...

    find the Modes lines in your file and remove the "Modes" setting that doesn't work, such as "1280x1024", leaving the setting that does work as the first setting on that line.

    hope that makes sense:

    Section "Screen"
    Identifier "Screen 1"
    Device "nVidia GeForce 5700FX"
    Monitor "Samsung SyncMaster 910T"
    DefaultDepth 24

    Subsection "Display"
    Depth 8
    Modes "1280x1024" "1024x768" "800x600" "640x480"
    ViewPort 0 0
    EndSubsection
    Subsection "Display"
    Depth 16
    Modes "1280x1024" "1024x768" "800x600" "640x480"
    ViewPort 0 0
    EndSubsection
    Subsection "Display"
    Depth 24
    Modes "1280x1024" "1024x768" "800x600" "640x480"
    ViewPort 0 0
    EndSubsection
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •