Find the answer to your Linux question:
Results 1 to 6 of 6
that's right i have no swap partition. i forgot to make one on the install. would that be why it took literally 30 minutes to boot the first time i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    23

    no swap partition


    that's right i have no swap partition. i forgot to make one on the install. would that be why it took literally 30 minutes to boot the first time i started mandriva? i have 1gig of ram btw. anyway, if i create a swap partition now, will mandriva know to use it?

    thanks,
    wes

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    with 1 gig of ram you don't need a swap IMHO. If you want ot add it, you will need to add the swap line to your /etc/fstab
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    I seriously doubt that the lack of a swap file is causing the slow boot. There's something else going on there.

    You don't have to have a swap file as long as you have plenty of ram. If you plan to run lots of apps at once, you might need one, though. You can create one if you have an unused partition on your drive. Use all of it for swap, or just delete it and then make two partitions out of it. Use one of them for the new swap partition, and use the other for whatever.

    Don't forget to add a new entry to your /etc/fstab file.

    AHHH... Vergil beat me to it! :P

  4. #4
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    Quote Originally Posted by Ozar
    AHHH... Vergil beat me to it! :P
    I didn't read the part about he slow boot

    look in /var/log/* or type dmesg and see if there are any errors on the boot
    Brilliant Mediocrity - Making Failure Look Good

  5. #5
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I agree as well. I run 512 RAM with no swap and have never missed it. The slow boot is a puzzle...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #6
    Just Joined!
    Join Date
    Jun 2005
    Posts
    23
    i can i ran dmesg, and found out two things:

    1.) i have dma disabled
    2.) i have lot's of I/O errors on various sectors

    i think my harddrive is dying, say a prayer for it will you please?

    unless it's the dma issue, but i'm planning the funeral.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •