Find the answer to your Linux question:
Results 1 to 6 of 6
I am a n00b using Mandrake Official 10.1 on a HP ZD7010us. I am trying to install Superkaramba 0.37rc1. When I try "./configure" I get; "checking for KDE... configure: error: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Los Angeles
    Posts
    8

    unsatisfied devel(libmcop)


    I am a n00b using Mandrake Official 10.1 on a HP ZD7010us. I am trying to install Superkaramba 0.37rc1. When I try "./configure" I get;

    "checking for KDE... configure: error: in the prefix, you've chosen, are no KDE headers installed. This will fail. So, check this please and use another prefix!"

    So after some reading up I find I need to install libkdecore4-devel-3.2.3-106.2.101mdk and libkdebase4-kate-devel-3.2.3-134.8.101mdk to install my kde headers. No problem, right? WRONG!

    When I try and install libkdecore4-devel-3.2.3-106.2.101mdk (with urpmi and/or Mandrake packager) I get the same error: "Some package requested cannot be installed: libkdecore4-devel-3.2.3-106.2.101mdk.i586 (due to unsatisfied devel(libmcop)) Continue? (Y/n) "

    libkdebase4-kate-devel-3.2.3-134.8.101mdk requires libkdecore4-devel-3.2.3-106.2.101mdk

    I have no idea what this error means and how to fix it. Any ideas anyone???

  2. #2
    Just Joined!
    Join Date
    Sep 2005
    Posts
    51
    Follow the instructions in my sig about easyurpmi and you'll find you have a lot more software available. Also you don't need to compile superkaramba - its packaged in one of the repositories you'll setup at easyurpmi

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Los Angeles
    Posts
    8
    Didn't I mention I tried urpmi? I already did the easyurpmi setup and what does that have to do with the error I am getting?

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Location
    Los Angeles
    Posts
    8
    Also, the first thing I did was to look for a prepackaged rpm of the newest version of Super Karamba 0.37. Not out there, otherwise why compile my own? and again, how does that address the error? I have seen this error message reported by other linux users when trying to compile other programs. I was hoping to find someone who understood the error and how to fix it.

  5. #5
    Just Joined!
    Join Date
    Sep 2005
    Posts
    51
    What I mean was to go to the easyuprmi site and setup access to the repositories - this will make a lot more software available through urpmi so there's a good chance it will then be able to resolve the depedency issue that's causing your error. Alternatively since there's a package for superkaramba in one the repos you setup you could choose to install that instead of compiling it.

    The reason so many other people have this error when trying to compile stuff is because Mandrake doesn't install the development packages for most software by default - to save space and reduce clutter. AFAIK they don't even have some them on the 3CD download set so that's why you need to go to easyurpmi and get access to the full repository.

  6. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    @ original poster
    try downloading an rpm for those kde-libs from http://rpm.pbone.net , then install it with this command:
    Code:
    rpm -iv --nodeps libkdebase4-kate-devel-3.2.3-134.8.101mdk
    then install the other package via urpmi. he nodeps option tells it to ignore any dependancies. I think, urpmi also has this option, but I can't remember for sure (see the man pages of urpmi for more info). if it does, then all you have to do is:

    Code:
    urpmi --<nodeps option name> libkdebase4-kate-devel-3.2.3-134.8.101mdk
    Hope this helps.
    Life is complex, it has a real part and an imaginary part.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •