Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Crossposting this thread from the Installation forum. I found a similar question... http://www.linuxforums.org/forum/pos...50.html#284150 I'm running into the same initial error on my HP NetServer LH 3r, when trying to install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    9

    Mandriva installation error on megaraid


    Crossposting this thread from the Installation forum. I found a similar question...

    http://www.linuxforums.org/forum/pos...50.html#284150

    I'm running into the same initial error on my HP NetServer LH 3r, when trying to install Mandriva 2005 LE (10.2) and have tried the installation as suggested "text noapic" with the same results.

    The error that I am getting is 'insmod'ing module megaraid ...'

    I believe I've tracked this down to needed to upgrade the megaraid controller's firmware.

    Any suggestions would be appreciated.

  2. #2
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    What model is your Megaraid? Or is this a onboard Raid solution?
    If it's an onboard solution you'll need toi get the firmware update from the motherboard manufacturers support site. If it's not an onboard solution, go to the following site to get the firmware file to update your controller.

    http://www.lsilogic.com/downloads/selectDownload.do

    You'll also need a bootdisk as well, I recommend getting the DRDos7 (Driver Free Disk For Bios Flashing) bootdisk as it doesn't load any memory management programs (memory management drivers can cause a flash to fail)

    http://www.bootdisk.com/

    Note: As with any BIOS flash or Firmware update you take the chance of rending the device useless. Be sure to follow the instructions to the "T" and don't remove power or reboot until directed to do so.
    Dell Precision T7400 Workstation
    Dual 3.33Ghz Xeon "Harpertown" Core
    16GB PC5300 DDR2 ECC CL5
    BFG GeForce GTX 285 OC 2GB
    X-Fi Platinum
    HP w2408 24" Monitor
    Dual Boot:openSUSE 11.2/Win 7 Ultimate

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    9
    The information I have noted on the MegaRaid is as follows:

    HP NetRaid
    MegaRaid T5
    Intel 82371AB PIIx4 IDE
    Symbios 53c895
    Firmware Revision, I believe, is D.03.02
    Server specs indicate the raid controller is intergrated on board.

    I reviewed the drop down at the LSI site, but I'm not recognizing the model of the MegaRaid controller. Is there something I can do on the system to ensure I have correct model information?

    I'm building this machine now for work, thanks for the fast reply

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    Go to this site and click on the "Download drivers and software (and firmware)" and search for HP Netraid. You will come up with quite a few models. Select the model you have and download the files.

    http://welcome.hp.com/country/us/en/support.html
    Dell Precision T7400 Workstation
    Dual 3.33Ghz Xeon "Harpertown" Core
    16GB PC5300 DDR2 ECC CL5
    BFG GeForce GTX 285 OC 2GB
    X-Fi Platinum
    HP w2408 24" Monitor
    Dual Boot:openSUSE 11.2/Win 7 Ultimate

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    9
    Forgive me as much of this is still a bit new to me... especially troubleshooting it...

    The error:
    insmod'ing module megaraid failed at /usr/bin/perl-install/modules.pm line 324

    Occurs during installation right after it attempts to install the driver for the Symbios|53c895. (which I've learned is the ulra wide scsi controller not a raid card)

    I clicked next. It tries again and fails again.
    I click next

    "Found "INTEL 82371AB PII4x IDE", "IBM MegaRaid T5, intergrated HP NetRaid", "Symbios|53c895." Any other devices?"

    I selected No and clicked Next

    "an error occurred - no devices were found on which to create new filesystems. Look at your hardware for the cause of this problem."

    Perhaps I'm looking in the wrong spots for a solution???

  7. #6
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    Symbios|53c895
    This is a SCSI controller made by LSILogic, it can either be used in a standard SCSI or Raid controller however the firmware will be the same. Where did you get the info that the controller was a HP Megaraid?
    Dell Precision T7400 Workstation
    Dual 3.33Ghz Xeon "Harpertown" Core
    16GB PC5300 DDR2 ECC CL5
    BFG GeForce GTX 285 OC 2GB
    X-Fi Platinum
    HP w2408 24" Monitor
    Dual Boot:openSUSE 11.2/Win 7 Ultimate

  8. #7
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    Is this a Compaq/HP computer by chance?
    Dell Precision T7400 Workstation
    Dual 3.33Ghz Xeon "Harpertown" Core
    16GB PC5300 DDR2 ECC CL5
    BFG GeForce GTX 285 OC 2GB
    X-Fi Platinum
    HP w2408 24" Monitor
    Dual Boot:openSUSE 11.2/Win 7 Ultimate

  9. #8
    Just Joined!
    Join Date
    Aug 2005
    Posts
    9
    Nothing specific told me that Symbios|53c895 was a HP MegaRaid ... I think I incorrectly assumed that from reading all of the information on the screen and not knowing where to distinguish seperate components.

    Yes it is... HP NetServer LH 3r
    Here is the spec sheet for the server model:
    http://www.rql.kiev.ua/RQL/old/HP/SE...LH3andLH3r.htm

    The best I can find is "Integrated dual-channel HP NetRAID disk array controller" under Controllers.

  10. #9
    Linux Engineer LondoJowo's Avatar
    Join Date
    May 2005
    Location
    Richmond, TX
    Posts
    804
    Thanks for providing the computer/server specs. Here's all the drivers/firmware. It appears that the latest firmware is D.03.04.

    http://tinyurl.com/9wxb6
    Dell Precision T7400 Workstation
    Dual 3.33Ghz Xeon "Harpertown" Core
    16GB PC5300 DDR2 ECC CL5
    BFG GeForce GTX 285 OC 2GB
    X-Fi Platinum
    HP w2408 24" Monitor
    Dual Boot:openSUSE 11.2/Win 7 Ultimate

  11. #10
    Just Joined!
    Join Date
    Aug 2005
    Posts
    9
    Okay ... On the system currently is Mandrake 9.1. I'm intending to rebuild the machine with Mandriva, but at least 9.1 is currently installed and working on this hardware.

    How would I be able to check to see what driver the SCSI controller is using currently? Is there config file or command I run to review that information?

    Would you suspect that this issue is a firmware issue? I have downloaded the newest versions of the bios and firmware. I have not yet applied them.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •