Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Something unfortunate happened to me as a guest unavare of what he was doing shutted down my server from the powerbutton (he tought he was starting it up). Well, now ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Location
    Helsinki, Finland
    Posts
    9

    Boot Problem - Error: read only filesystem


    Something unfortunate happened to me as a guest unavare of what he was doing shutted down my server from the powerbutton (he tought he was starting it up).

    Well, now when i start the server all processes end up with [ FAILED ], and as error message i get a complaining that the filesystem is read only. So it cant delete or create any runfiles...

    I manage to login if i choose the failsafe option from the bootloader, and thus am able to do some limited things.

    I ran the e2fsck with -pf on all partitions but that didnt help.

    Does anyone have a clue what i could do except reinstalling the system.

  2. #2
    Just Joined!
    Join Date
    Aug 2005
    Location
    Helsinki, Finland
    Posts
    9
    More details to help you diagnose my problem.

    Running fdisk results:
    Code:
    [root@(none) /]# fdisk -l
    cannot open /proc/partitions

  3. #3
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    So e2fsck found no problem? And you ran it on the / filesystem?

    What happens if you try to mount /?

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    If you want to skip the long bootup process, a quick way into a failsafe is to add:
    Code:
    init=/bin/bash
    To your boot options, which will yield a root console. From there:
    Code:
    mount -no remount,rw /

  5. #5
    Just Joined!
    Join Date
    Aug 2005
    Location
    Helsinki, Finland
    Posts
    9
    Quote Originally Posted by anomie
    So e2fsck found no problem? And you ran it on the / filesystem?
    I ran,
    Code:
    e2fsck -pf /dev/hda1
    e2fsck -pf /dev/hda6
    (thats all of my partitions)
    Quote Originally Posted by anomie
    What happens if you try to mount /?
    It says:
    Code:
    mount: /dev/hda1 already mounted or / busy
    mount: according to mtab, /dev/ide/host0/bus0/target0/lun0/part1 is alredy mounted on /
    Quote Originally Posted by lakerdonald
    If you want to skip the long bootup process, a quick way into a failsafe is to add:
    Code:
    init=/bin/bash
    To your boot options, which will yield a root console. From there:
    Code:
    mount -no remount,rw /
    Thanks for the advice, i will try this even though i didnt really understand what it will do (i guess ill find out)...

  6. #6
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    You'll need to:
    Code:
    umount /dev/...
    before running fsck.

    edit:
    heh just thought about that and realized that you're not on a livecd so that wouldn't work
    heh

  7. #7
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    You need to get to single-user mode before running the filesystem check on /.

    Try
    Code:
    init 1
    as root (after booting).

  8. #8
    Just Joined!
    Join Date
    Aug 2005
    Location
    Helsinki, Finland
    Posts
    9
    Ok so i do after boot
    Code:
    init 1
    umount /
    should i then do
    Code:
    e2fsck -pf /dev/hda1
    (or)
    e2fsck -pf /

  9. #9
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    Well, assuming /dev/hda1 is where you mount /, then run it on the device itself - /dev/hda1. (At times when the file system check program can get to /etc/fstab you can use either one.)

  10. #10
    Just Joined!
    Join Date
    Aug 2005
    Location
    Helsinki, Finland
    Posts
    9
    Ok i did that now and i get a clean report from all partitions now as well.

    But the error persists, upon boot (and shutdown, which i did forget to mention earlier) anything the loader does is responded by either;

    a) IOError [Errno 30] Read only filesystem
    b) [Errno 30] Read only filesystem
    c) Read only filesystem

    accompanied with the name of some file or pid that it tried to operate on.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •