Find the answer to your Linux question:
Results 1 to 5 of 5
Hi I am trying to install the Smartlink PCI562 Modem on my Mandrake 10.1 Community Intall. As part of the requirements for the drivers that I downloaded from the manufacturer, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Location
    Dublin, Ireland
    Posts
    29

    Kernel Source Tree - Smartlink PCI562 Modem Install


    Hi

    I am trying to install the Smartlink PCI562 Modem on my Mandrake 10.1 Community Intall.

    As part of the requirements for the drivers that I downloaded from the manufacturer, the driver needs the full kernel source tree (2.6.x.x) to be installed and configured.

    Can some explain how I can get hold of the source files and how to install them and configure them?
    I have the install CDs 1-3 but cant seem to find the source files.

    Any advice that anyone can provide would be very much appreciated

    Cheers
    NeilB

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    on mandrake, try:

    Code:
    urpmi kernel-source
    that should install the source tree for you.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Posts
    51
    It might be called kernel-source-2.6. You might have to go to easyurpmi (see my sig) first and setup the repositories to get it.

  4. #4
    Just Joined!
    Join Date
    Oct 2004
    Location
    Dublin, Ireland
    Posts
    29
    Hi thanks for your reply.

    I installed the source for linux-2.6.8.1.-25mdk by mistake.

    But my running kernel is 2.6.8.1-10mdksmp
    How do I uninstall this kernel source to install the 8.1-10 source?

    I have tried clearing the urpmi cache and deleteing the directory from the usr/src directory. But everytime i run the 'urmpi kernel-source' command it keeps saying 'Everything is already installed'

    Thanks again for all yor help guys
    NeilB

  5. #5
    Just Joined!
    Join Date
    Sep 2005
    Posts
    51
    For some reason kernel updates do not come through the normal Mandrake Update mechanism (you have to do it specially following the commands here: http://www.mandriva.com/security/kernelupdate). However the kernel-source package does get updated normally through Mandrake Update. So when you tell urpmi to install kernel-source it will first look in the updates to make sure it gets the latest package (as it does with any program).

    So in short the solution to this is to just get the updated kernel package as described in that link - technically you should be doing that anyway but of course Mandrake has made it neither easy nor well known to users that that's what they have to do.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •