Find the answer to your Linux question:
Results 1 to 2 of 2
hi! on mdk10.1 official, i was tinkering with the media manager, this used to exist, Supplementary Applications CD4 (cdrom7), i changed some values (put in a proxy server), tried to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    35

    urpmi (adding a media source)


    hi!

    on mdk10.1 official, i was tinkering with the media manager, this used to exist, Supplementary Applications CD4 (cdrom7), i changed some values (put in a proxy server), tried to save, it didnt accept, i removed the proxy values, dont want to save anymore. i tried to remove, and then add. failed. so i tried this:

    urpmi.addmedia "Supplementary Applications CD4 (cdrom7)" removable://mnt/cdrom/media/main5 with ../../media/media_info/hdlist8.cz

    and got this:

    added medium Supplementary Applications CD4 (cdrom7)
    examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Installation CD 3 (cdrom3).cz]
    examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Supplementary Applications CD 5 (cdrom.cz]
    examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Installation CD 2 (cdrom2).cz]
    examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Installation CD 3 (cdrom6).cz]
    examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Commercial Applications CD 6 (cdrom10).cz]
    examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Commercial Applications CD 6 (cdrom9).cz]
    examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Installation CD 1 (cdrom1).cz]
    examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Installation CD 3 (cdrom5).cz]
    examining synthesis file [/var/lib/urpmi/synthesis.hdlist.Installation CD 3 (cdrom4).cz]
    unable to access medium "Supplementary Applications CD4 (cdrom7)",
    this could happen if you mounted manually the directory when creating the medium.
    unable to update medium "Supplementary Applications CD4 (cdrom7)"

    in the installation manager, i can no longer see some software i used to be able to add. i thought perhaps if i can add this cd 4 media source, perhaps i can install the way i used to, using the install software option.

    help pls?

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    52
    jeisma,

    I do not use CD media, so I cant help there. If you have a decent internet connection perhaps you could remove all your CD media and just use a mirror? I'll post how here, but if you already know that and just need your CD back I apologize in advance.


    Here is how you want to update.


    Before you do anything else you should probably get rid of your exisiting media in your repository.

    Please read here http://mandrake.vmlinuz.ca/bin/view/Main/UsingUrpmi if you need a refresher on URPMI!

    i.e. urpmi.removemedia -a

    Then lets get some new sources:

    First make sure you know what version you have:
    10 community
    10 official
    10.1 community
    10.1 official

    etc.


    then go to http://easyurpmi.zarb.org/ and pick your version and your arch. (ie. i586)

    MAKE SURE YOU CLICK PROCEED TO STEP 2!!

    Then select what you are looking for,
    i.e. Main, Update, Contribution and choose your mirrors.

    Then click proceed to step 3

    You will find some text that you can copy and paste into your console as root
    i.e. :

    urpmi.addmedia main ftp://mirrors.usc.edu/pub/linux/dist...Mandrake/RPMS/ with ../base/hdlist.cz
    urpmi.addmedia contrib ftp://mirrors.usc.edu/pub/linux/dist.../contrib/i586/ with ../../i586/Mandrake/base/hdlist2.cz

    Paste that into your console as root and enter. It will download the lists for you and configure them as media for your system.

    You could then use urpmi from the console to stay up to date.
    i.e. :

    urpmi.update -a updates all those sources you just grabbed, do this before you update or install packages so you have the lates.

    urpmi --auto-select will upgrade everything you have to the latest.

    urpmi -y <packagename> will search for it. it will list all packages that match. Be careful, if there is only one match it will install it

    also see urpmq and urpme

    Have fun.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •