Find the answer to your Linux question:
Results 1 to 6 of 6
Hello fellow linux folks, I know that this is likely an old topic ... but what can I say? This is my first posting. Have not had to in the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Location
    Charlotte, VT
    Posts
    3

    Problems Getting Madwifi to Work on Mandrake 10.1


    Hello fellow linux folks,

    I know that this is likely an old topic ... but what can I say?

    This is my first posting. Have not had to in the past as I have been able to figure most things out myself. Not this time though. OK, here is the story.

    I have Mandrake 10.1 (kernel 2.6.8.1-12mdk) loaded on this machine. Works great! I used to have the wireless side (using madwifi, but can't remember the version) working just fine, but then one evening when I powered up the machine it was gone. Since then have not been able
    to figure out why.

    So I went over to windows (since the network is down and the wg511t card works fine on windows) and download the latest madwifi driver. Compiled and installed it. Made the appropriate changes to the kernel files and indicated in the FAQ. No compiling errors, everything went just fine. But the system cannot connect to the network. It just reports "Network is unreachable." Note that only the power LED on the back of the card it lit - the other one never comes on. (does in windows).

    When I reboot, the PC hangs for quite some time on:

    "Bringing up interface ath0"

    followed by several zcip[2589] .... statements.

    I can stop this if I tell linux to not boot the network at startup.

    Below are some snapshots of the results of various commands (iwconfig, iwlist, ping). Can anyone give me some idea of what I should check? Most strange.

    Tnx,
    Les

    --------------------------

    Results of iwconfig:

    [root@localhost etc]# iwconfig
    lo no wireless extensions.

    Warning: Driver for device ath0 recommend version 18 of Wireless Extension,
    but has been compiled with version 16, therefore some driver features
    may not be available...

    ath0 IEEE 802.11g ESSID:"BladesWAN" Nickname:"localhost"
    Mode:Managed Frequency:2.437 GHz (Channel 0) Access Point: 00:09:5B: F8:02:41
    Bit Rate=54 Mb/s
    Encryption key:3F3E-BAFF-612C-DD4B-164F-1C6E-6D Security mode:restricted cted
    Link Quality:37/100 Signal level:-71 dBm Noise level:-256 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    eth0 no wireless extensions.

    sit0 no wireless extensions.

    -------------------
    And the results of iwlist ath0 scan

    [root@localhost etc]# iwlist ath0 scan
    Warning: Driver for device ath0 recommend version 18 of Wireless Extension,
    but has been compiled with version 16, therefore some driver features
    may not be available...

    ath0 Scan completed :
    Cell 01 - Address: 00:09:5B:F8:02:41
    ESSID:"BladesWAN"
    Protocol:IEEE 802.11g
    Mode:Managed
    Frequency:2.437 GHz (Channel 0)
    Quality:0/100 Signal level:-68 dBm Noise level:-256 dBm
    Encryption key:on
    Bit Rate:1 Mb/s
    Bit Rate:2 Mb/s
    Bit Rate:5.5 Mb/s
    Bit Rate:11 Mb/s
    Bit Rate:6 Mb/s
    Bit Rate:9 Mb/s
    Bit Rate:12 Mb/s
    Bit Rate:18 Mb/s
    Bit Rate:24 Mb/s
    Bit Rate:36 Mb/s
    Bit Rate:48 Mb/s
    Bit Rate:54 Mb/s
    Extra:bcn_int=100
    Extra:atim=0

    -----------------------------

    Results of ping (pinging the router):

    [root@localhost etc]# ping 192.168.1.1
    connect: Network is unreachable
    [root@localhost etc]#

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Sounds like maybe you have your network configured to be DHCP and it should be static. Is that true?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Location
    Charlotte, VT
    Posts
    3
    Jeremy,

    Yes the network/router is configured for DHCP - which is what it has always been. Setting it to a static IP address has no effect. Any other ideas?

    Tnx,
    Les

  4. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Can you post the results of this command
    Code:
    ifup eth0
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  5. #5
    Just Joined!
    Join Date
    Sep 2005
    Location
    Charlotte, VT
    Posts
    3
    Jeremy -

    I would be glad to post the results of ifup eth0. The results are below. Please note that with the linux box located downstairs and not able to connect to my home network (no cable downstairs) I have to restart in windows every time to connect to the network. A real pain in the neck. I could temporarily move it upstairs and run an ethernet cable directly from the router to the computer - but have not wanted to do that. Just a royal pain.

    Anyway, below are the results of ifup eth0 and ifup ath0.

    I have also include the results of dhclient ath0, in case this helps any.

    [root@localhost lblades]# ifup eth0
    Determining IP information for eth0...
    done.
    /sbin/ifup: line 466: 4218 Hangup /etc/init.d/tmdns reload >/dev/null 2>&1
    [root@localhost lblades]#
    [root@localhost lblades]# ifup ath0

    Determining IP information for ath0... done.
    /sbin/ifup: line 466: 4348 Hangup /etc/init.d/tmdns reload >/dev/null 2>&1
    [root@localhost lblades]#

    and for dhclient ...

    [root@localhost lblades]# dhclient ath0
    Internet Systems Consortium DHCP Client V3.0.1
    Copyright 2004 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/products/DHCP

    sit0: unknown hardware address type 776
    sit0: unknown hardware address type 776
    Listening on LPF/ath0/00:0f:b5:1e:c1:a5
    Sending on LPF/ath0/00:0f:b5:1e:c1:a5
    Sending on Socket/fallback
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 5
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 5
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 13
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 18
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 12
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 4
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.

    Once again, tnx for taking the time to help me on this.

    Les

  6. #6
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    I curse Mandriva. This samething happened to me. You might try disabling tmdns, although that may or may not work. Went it happened to me, the problem was that I had no gateway assigned. Do you have one assigned?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •