Find the answer to your Linux question:
Results 1 to 4 of 4
Hi I am a complete n00b here, but need help if you can. I have installed three versions of Linux and settled on Mandriva. I have tried various different dial ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    6

    Madriva Linux Dial up problem


    Hi I am a complete n00b here, but need help if you can. I have installed three versions of Linux and settled on Mandriva. I have tried various different dial up modems, and have even bought an external zoom serial modem. Linux recognized the modem, but when it dialed out it said it appears you are not connected.

    I have set up a kppp session, and the modem dials out, and connects, but when ever I try to access web pages it says it cant, and I can't ping web sites either. Yet I know its authenticating cause it says there was a problem if I put in the wrong password. I have tried setting up DNS in the resolv.conf and am now comepletely stuck... any ideas please? would be most grateful.

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    I don't have an idea of what your problem is, but if I was at your machine, I would attempt to connect, and while watching the lights on the modem to make sure that the connection is not lost, I would do the command '/sbin/ifconfig ppp0' to see the line that starts with "inet addr:" and then the command 'route -n' to see the line(s) that includes the value "ppp0". Those lines will show if you have 1) an IP address assigned by your ISP, which you must for internet access and 2) a route to the rest of the world through your modem connection something like this:
    Code:
    # /sbin/ifconfig ppp0
    ......
              inet addr:66.22.144.18  P-t-P:67.92.110.15  Mask:255.255.255.255
    ...... 
    # route -n
    ......
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    67.92.110.15    0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
    0.0.0.0         67.92.110.15    0.0.0.0         UG    0      0        0 ppp0
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Linux Newbie
    Join Date
    Dec 2004
    Location
    Texas, USA
    Posts
    107

    modem help

    Disable your firewall temporarily. start>config your comp (MCC) >security>Firewall
    Also check configuration settings in Kppp. It's been awhile since I used dialup but check:
    set dev to ttsy0
    authent to PAP/CHAP
    hardware flow

    you can google for some init strings although for now leave all the other settings alone on that tab. Contact Harry at Hayes/Zoom... he will email you some init strings.

    Type ATZ in test tab, if the response is OK, then your modem is recognized.
    Also, if possible, dial out, then listen in on an extension phone to see if you can hear the warbling sound of the "handshake".

    As soon as I got rid of AOL, I was online. Some ISPs don't play nice with linux. (AOL requires a special dialer script)

    Good luck

  4. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    6

    Thanks

    Thank you guys for your help... yeah the lights stayed on, and so I checked the firewall, which being such a n00b didnt even know was running with Linux. I turned the firewall off and it worked... so I did some more forum searching and found a way to set the firewall to ppp rather than ethernet aware, rebooted, and that was fine...

    For anyone in similar boat

    run konsole
    log in as su and open kwrite
    file open /etc/shorewall/interfaces

    replace this line...

    "net eth0 detect"

    with

    "net ppp+ detect" (leaving the quotes)

    I restarted the os and logged in and connected... again thank you guys for your help


    Ryan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •