Find the answer to your Linux question:
Results 1 to 3 of 3
Hi folks, I'm using Earthlink DSL. I'm dual booting WindowsXP and Mandriva 10.1 When I boot into Windows all web page lookups are really fast. When I boot into Linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2

    Browsing problem - Please help.


    Hi folks,

    I'm using Earthlink DSL. I'm dual booting WindowsXP and Mandriva 10.1

    When I boot into Windows all web page lookups are really fast.
    When I boot into Linux the exact same web pages have more than a 20 second delay.

    What could cause this? Firewall too tight? DNS lookup problem?

  2. #2
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Does the problem persist no matter which browser you use? If so, there was an IPV6 "bug" in SuSE 9.2 that sounds a lot like what you're talking about.

    Not sure what it is in Mandriva, but in ubuntu or SuSE,
    1. edit /etc/modprobe.d/aliases with your favorite text editor
    2. Find the line: alias net-pf-10 ipv6
    3. Edit this to: alias net-pf-10 off
    4. Save the file and reboot
    Your browsing should now be a lot faster.

    Also: Here's something for broadband people that will really speed Firefox up:

    1.Type "about:config" into the address bar and hit return. Scroll down and look for the following entries:

    network.http.pipelining network.http.proxy.pipelining network.http.pipelining.maxrequests

    Normally the browser will make one request to a web page at a time. When you enable pipelining it will make several at once, which really speeds up page loading.

    2. Alter the entries as follows:

    Set "network.http.pipelining" to "true"
    Set "network.http.proxy.pipelining" to "true"

    Set "network.http.pipelining.maxrequests" to some number like 8. This means it will make 8 requests at once.

    3. Lastly right-click anywhere and select New-> Integer. Name it "nglayout.initialpaint.delay" and set its value to "0". This value is the amount of time the browser waits before it acts on information it receives.

    If you're using a broadband connection you'll load pages MUCH faster.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2

    All browsers exhibit the same slowness

    Flatline,

    Those are very helpful suggestions. They worked perfectly to fix my problem. The only thing I would add is that to turn of IPV6 in Mandriva do the following:

    # echo "alias net-pf-10 off" >> /etc/modprobe.conf
    Then just reboot.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •