Find the answer to your Linux question:
Results 1 to 9 of 9
Hello, I just recently installed Mandrake Linux 10.1 on my new system. The specs are: AMD Sempron 2800+ CPU, Gigabyte GA-K8U Mobo, MSI Geforce 6200 video card, and 512MB RAM. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4

    Won't load GUI


    Hello, I just recently installed Mandrake Linux 10.1 on my new system. The specs are: AMD Sempron 2800+ CPU, Gigabyte GA-K8U Mobo, MSI Geforce 6200 video card, and 512MB RAM.

    What my problem is that when I start up Linux, I get no GUI. I get the command menu thing. Is this something to do with my video card? Because when I installed Mandrake, I couldn't find my drivers for the video card so I left it unconfigured and I figured I would find the right drivers once I got it installed. Well, my guess is that was a bad idea. Is there anything I can do? My friend mentioned to me that I could get the right drivers downloaded through the command area, but how can this be done?

    Thanks in advance,
    AnthraX

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    first of all from the cli to start x you need to type "startx"
    If x isn't configured you can run a script called xorgcfg that should configure a useable one for you...if it messes up, then ctl-alt-f1 and tell us what errors you are getting.
    Operating System: GNU Emacs

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4
    I actually did that last night and it just did the same thing. I didn't do the error thing. I'll try that when I get home, I'm at work right now. But thanks, is there any other things I should try if this doesn't work?

  4. #4
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    well, first lets see the errors you get, if it still shows text you can just post that, or if it startx the xserver in vt7 then you can ctl-alt-f1 to get the error messages, post those back and we'll see what we can come up with...
    Operating System: GNU Emacs

  5. #5
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4
    Well I do the xorgcfg and it kinda hangs for a little bit. Nothing is showing on my monitor. Then I hit the ctrl+alt+1, and it shows like a list of drivers that it's been cycling through. I've done it twice and it seems like it keeps getting hung on the voodoo drivers. Should I just wait longer?

    P.S. What does the ctrl+alt+1 thing do?

  6. #6
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Have you tried reinstalling your OS from the disk (actually you don't need to do a full reinstall, just an 'upgrade' or something). The idea is to get to the options to configure your video card ... You might be able to tweak a couple of settings in there and get things working.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  7. #7
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4
    Yeah, I've tried that about 5 times. Nothing has worked. Lately I've been downloading Fedora Core 4, and hopefully that will automatically support my video card.

  8. #8
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Have you tried just loading the nv module and specifying that module in your /etc/X11/xorg.conf file? (warning: always backup ANY config file before you modify it). You may be able to "force" the system to use the correct driver that way.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  9. #9
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    You could try running the config tool again, use Vesa drivers and update to the nVidia drivers later when you get up and running. There is a tool called xfdrake that should run from the command line. The nv driver will be fine for you to start with, but if you have trouble there try the standard vesa driver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •