Find the answer to your Linux question:
Results 1 to 3 of 3
this may sound a bit advanced but i have rmeoved most of the nice menus that would have allowed me to easily redo this. I need ot be able to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2

    Manually setting up mandrake 10.1 powerpack for adsl with ethernet


    this may sound a bit advanced but i have rmeoved most of the nice menus that would have allowed me to easily redo this.
    I need ot be able to connect the linux machne to my speadstream 6520 router (it also is the adsl modem)
    any one able to help id much appreciate it
    remember this is a manual doing no menu nicies, and i am able to follow instructions, having used it on cable without problems( initially set up for a cable modem via ethernet no problems)
    need to know which files to modify and change.
    and it is a PPoE connection and the modem/router also i believe acts as the dchp
    im sure about PPPoe not sure about dchp.

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    A rough guide -

    Hi - You'll need to configure your router in some way. For example mine worked by accessing it from a web browser and typing in the router's address: 192.168.1.1 .... Yours might be similar. You'll need the right settings from your ISP. Remember to enable your router's firewall. Don't use Konqueror to do this: I had some problems using that.

    DCHP isn't too hard to use ... in fact it's the key to accessing the web with a router. I set this up while logged on as root. Try dhcpcd -n eth0 This assumes that your ethernet card is eth0 and not eth1. Check the manual for further details.

    ifconfig is an essential command. Also as root, type ifconfig eth0 192.168.1.1 up (do this first). This assumes your router's address is the same as mine. Change as applicable.

    Also type route to display a table of network devices. Type ifconfig (on its own) to show more complete information. You need to look at the line that looks like:

    inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0

    If it reads inet addr:000.000.0.0 something is wrong.

    Try pinging your router. For example, ping -c 10 192.168.1.1

    You'll know you are connected if you can ping external sites. Try ping -c 10 www.google.com

    This might help - Goodnight
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2

    well i messed it up bad

    reintalled and auto detected .... dont yah love mandrake
    even xp won't do all this.
    thanks btw
    ill leave certain things alone this time round.
    ....now its to make it so a windows box can share files with a linux one ugh....
    then lets get all this stuff off this one and make it linux
    what a breeze it all is, it amazes me how simple it is out of the box.
    not only does it not need any setups but worked like a charm, simply setup a file share user , open ftp prog and wella, close ftp server and woot
    and vice versa.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •