Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 33
I'm trying to load a game after instaling my NVIDIA drivers and the following code is accuring when I load it through the terminal: Xlib: extension "GLX" missing on display ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! david_b.'s Avatar
    Join Date
    Sep 2005
    Location
    Estonia
    Posts
    62

    Games not loading !


    I'm trying to load a game after instaling my NVIDIA drivers and the following code is accuring when I load it through the terminal:

    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Couldn't set video mode: Couldn't find matching GLX visual
    Error in bool sr_InitDisplay() in rScreen.cpp:566 :

    Sorry, played all my cards trying to initialize your video system.
    Armagetron won't run on your computer. Reason:

    Couldn't set video mode: Couldn't find matching GLX visual

    I'll try again from the beginning, but the chances of success are minimal.

    Fatal signal: Segmentation Fault (SDL Parachute Deployed)

  2. #2
    Just Joined! david_b.'s Avatar
    Join Date
    Sep 2005
    Location
    Estonia
    Posts
    62
    Anybody finds this problem familiar ?
    Thanks in advance...

  3. #3
    Banned
    Join Date
    Jul 2004
    Posts
    947
    have you edited your xorg.conf?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! david_b.'s Avatar
    Join Date
    Sep 2005
    Location
    Estonia
    Posts
    62
    Yes, I changed *nv* to *nvidia*. That's all I thought I need to do...

  6. #5
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    you also have to change a few more things in the x.org file, namely:

    find these lines:
    Load "dri"
    Load "GLCore"
    replace both with
    Load "glx"
    you can also comment out the Load "dri" part by placing a # in front of the Load option.
    Life is complex, it has a real part and an imaginary part.

  7. #6
    Just Joined! david_b.'s Avatar
    Join Date
    Sep 2005
    Location
    Estonia
    Posts
    62
    The xorg.conf looks fine, the lines arent there (load "dri" and "glcore"), and the line Load "glx" is ok

  8. #7
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Have you installed Open GL? Asking just in case
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  9. #8
    Just Joined! david_b.'s Avatar
    Join Date
    Sep 2005
    Location
    Estonia
    Posts
    62
    No, I installed NVIDIA Drivers and thought Open GL would be installed automatically with them as it was in Windows. Didn't they ?

  10. #9
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by david_b.
    No, I installed NVIDIA Drivers and thought Open GL would be installed automatically with them as it was in Windows. Didn't they ?
    Yes, you do not need to separately install OpenGL to get the Nvidia drivers to work. Nvidia installs their own libGL.so files when you install the driver. What video card do you have?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  11. #10
    Just Joined! david_b.'s Avatar
    Join Date
    Sep 2005
    Location
    Estonia
    Posts
    62
    I have Chaintech Nvidia GeForce MX 400/200, 64 MB !

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •