I am a newbie trying to print to a WindowsXP printer on my home network (no password) It's simply doesn't work on Mandriva 10.1 Official or Mandriva 2006, though the error are different.

1) I run: smbclient -L COMPAQ -N and it clearly shows the Win PC and its attached printer.
Domain=[COMPAQ] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
Sharename Type Comment
--------- ---- -------
IPC$ IPC Remote IPC
print$ Disk Printer Drivers
SharedDocs Disk
hpoffice Printer hp officejet v series
C Disk
ADMIN$ Disk Remote Admin
C$ Disk Default share
Domain=[COMPAQ] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

2) I try to set up the printer using Lpadmin and it just *hangs* :lpadmin -E -p officejet -v smb://COMPAQ/hpoffice -P /root/inkjet.ppd (I've tried it with :@ in the smb string to signify no useridassword)

3) I look in /var/log/cups/error_log and I see things (with Mandriva 2006) like:Unable to connect to SAMBA host, will retry in 60 seconds...ERROR: No ticket cache found for userid=0
Can not get the ticket cache for root
Tree connect failed

4) I have tried the CUPS localhost:631 and it creates the printer fine, but the jobs never come out, they just time out , unable to connect messages in the error_log

Any thoughts would be appreciated.
Charlie