Find the answer to your Linux question:
Results 1 to 2 of 2
Hey, I've been trying to get autofs working on my Mandrake 10.2 box. Specifically, I am trying to set it up so that it will auto mount and unmount my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4

    HELP! autofs not working on Mandrake 10.2


    Hey,

    I've been trying to get autofs working on my Mandrake 10.2 box. Specifically, I am trying to set it up so that it will auto mount and unmount my CD and DVD writers, and my MP3 player whenever put media in and go to the respective mount points. The problem is that autofs never seems to see that I have put any media in. I can mount/umount each of the items by command line, and see the data in each of the media then, but autofs is not doing it automatically.

    I have looked in /var/log/messages, and apart from messages showing when I have started and stopped autofs, there are no other autofs messages, i.e. it doesn't seem to be responding to my entering one of the mount directories that should be automounted.

    Here is my /etc/auto.master file:
    #
    # $Id: auto.master,v 1.3 2003/09/29 08:22:35 raven Exp $
    #
    # Sample auto.master file
    # This is an automounter map and it has the following format
    # key [ -mount-options-separated-by-comma ] location
    # For details of the format look at autofs(5).

    /mnt/floppy /etc/auto.floppy --timeout=1
    /mnt/cdrom /etc/auto.cdrom --timeout=3
    /mnt/dvd /etc/auto.dvd --timeout=3
    /mnt/mp3player /etc/auto.mp3player --timeout=3

    -------------------
    Here is a sample map file /ect/auto.dvd:
    #==== /etc/auto.cdrom (has 3 second timeout)
    dvd -fstype=iso9660,ro,nosuid,nodev,user :/dev/cdrom

    -------------
    And here is what my /etc/mtab looks like:
    /dev/hda5 / ext3 rw 0 0
    none /proc proc rw 0 0
    none /proc/bus/usb usbfs rw 0 0
    none /sys sysfs rw 0 0
    /dev/hda7 /home ext3 rw 0 0
    /dev/hda1 /mnt/win_xp ntfs rw,umask=0000,nls=iso8859-1 0 0
    /dev/hdb7 /mnt/d_drive vfat rw,umask=0000,iocharset=iso8859-1,codepage=850 0 0
    /dev/hdb6 /mnt/oldhome ext3 rw 0 0
    /dev/hdb2 /mnt/oldroot ext3 rw 0 0
    nfsd /proc/fs/nfsd nfsd rw 0 0
    none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
    automount(pid28595) /mnt/floppy autofs rw,fd=4,pgrp=28595,minproto=2,maxproto=4 0 0
    automount(pid28636) /mnt/cdrom autofs rw,fd=4,pgrp=28636,minproto=2,maxproto=4 0 0
    automount(pid28677) /mnt/dvd autofs rw,fd=4,pgrp=28677,minproto=2,maxproto=4 0 0
    automount(pid2871 /mnt/mp3player autofs rw,fd=4,pgrp=28718,minproto=2,maxproto=4 0 0

    I hope someone can help me.
    Thanks
    Norman

  2. #2
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4

    I've fixed (this) problem

    I've solved the problem of autofs not seeing the drives. It turns out it was my own stupidity.

    I was cd'ing to /mnt/auto_mounted_drive
    when I should have been going to:
    /mnt/auto_mounted_drive/auto_mounted_drive

    So now my removable drives are automatically mounting. They just aren't unmounting...
    Norman

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •