Find the answer to your Linux question:
Results 1 to 7 of 7
At first, this might seem like I am requesting help for GAIM. After thinking about this, I decided that this has to do with a general Linux issue rather than ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Posts
    2

    GTK problems in Mandriva 2006


    At first, this might seem like I am requesting help for GAIM. After thinking about this, I decided that this has to do with a general Linux issue rather than a specific program. I'll give some background information first of all. I know how to follow explicit directions, but amigious directions will confuse the hell out of me as my Linux experience is completely personal and quite limited. I am running the free version of Mandriva 2006 (and for the purpose of a comment later, Windows XP Pro using Cygwin.)

    I have heard about CVS and had no experience in it and the idea appealed to me to be able to test out a program that was being developed. I decided to try to get the CVS of GAIM 2.0.0 because I was tired of waiting for the stable version. Following the directions from GAIM's site, I was able to successfully compile GAIM 2.0.0cvs for Windows. I decided that I should get Linux and try to do the same thing there to educate myself on how the same thing works in different environments. I was able to get the CVS just fine in Linux, followed the directions on setting it up to compile and received on odd error. It said I don't have GTK installed. That's odd... I swore I had The GIMP installed. Sure enough, the program ran just fine. I even installed the pre-compiled version of GAIM 1.5.0 and it ran just fine. I believe I'm using GTK 2.7 or 2.8.

    What would cause a program that required GTK, such as The GIMP, to work if GTK wasn't installed in the system? If that's impossible, what would cause a configuration file to not find GTK on the system? Moreso, how do I solve this problem of GTK not being able to be found?

    I've also tried to use configure for GAIM 1.5.0 and The GIMP, neither of the configures were able to find GTK at ALL. Not a version that was too old or not compatible, just missing entirely...

    I'm pretty confused as to what to do. I even tried to compile GTK from scratch receiving errors such as Pambo not being present (which is wrong as it, too, is installed).

    Obviously there's some setting that is wrong out of the box that I need to fix but I'm at a loss as to what to do.

    Thank you for your time for reading this post and I hope I can work with someone to solve my problem.

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    I haven't installed gaim from source in a long time, but I think it requires gtk 1.2 or something like that. Now gtk 2 is not backwards compatible with gtk1, so you may need to install gtk1 on your system. To do that, use urpmi or install gtk 1 from source.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Nov 2005
    Posts
    2
    Code:
    checking for pkg-config... /usr/bin/pkg-config
    checking for GLIB - version >= 2.0.0... yes (version 2.8.1)
    checking for pkg-config... (cached) /usr/bin/pkg-config
    checking for GTK+ - version >= 2.0.0... no
    *** Could not run GTK+ test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occurred. This usually means GTK+ is incorrectly installed.
    configure: error:
    *** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
    *** development headers installed. The latest version of GTK+ is
    *** always available at http://www.gtk.org/.

    I HAVE GTK+ >=2.0.0 To prove this, GIMP 1.x and GIMP 2.2 work correctly It's pretty frustrating when you have limited knowledge in how to do Linux sutffs

  4. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    *** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
    *** development headers installed.
    The latest version of GTK+ is
    That shows you need the gtk headers, you have the package, just not the development headers. I think the package you need to install is called gtk-devel or something along those lines.
    Life is complex, it has a real part and an imaginary part.

  5. #5
    Just Joined!
    Join Date
    Dec 2005
    Posts
    2

    gtk+2.0-devel do not come with mandriva 2006 free edition

    gtk+2.0-devel do not come with mandriva 2006 free edition.

    Even if you are updating mandriva 2005 le or an other mandrake installation there eare many problems like broken symbolic links in /usr/lib (so many).

    The gtk+2.0-devel rpm is very difficult to find (http://rpmfind.net do not have a link for this rpm for mandriva 2006).

    Mandriva 2006 free is a fiasco for the developer.

    May yuo have to go to another gnu-linux distribution like debian, or fedora core, that are ready for the developer. Ububtu is very good, but a ADSL conection to internet is needed if you want the development packages and environmet, like gcc an so on.

    I have the same problems compiling wxgtk, this library comes whit mandriva 2006 free, but only as shared object and not for development.

    Many development pakages are ausent in mandriva 2006 free, is time to say godbye to mandrake tradition of exelent development support!

  6. #6
    Just Joined!
    Join Date
    Dec 2005
    Posts
    2

    In http://rpm.pbone.net con find llibgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i58

    I have find some rpms for mandriva 2006 in

    http://rpm.pbone.net/

    search for: libgtk+2.0_0-devel-2.8.3-4.2

    I not know if may need other rpm's like other devel libs, but in rpm.pbone.net is sure to find that libraries.

    the following link search the library libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586.rpm :

    http://rpm.pbone.net/index.php3/stat....i586.rpm.html

    You may to check de log file of your compilation, see for gtk+2.0 testing program, there is a more explicit description of the compiling problem. Go as root to /usr/lib and search for the bad symbolic link, remove and make a new declaration of the same symbolic link targeting to the updated souce of the link.
    as a example, you want to update the following symbolic link:

    /usr/lib/libgtkhtml-2.so.0.0.0

    as root go to /usr/lib:

    cd /usr/lib

    then search for libgtkhtml*

    you may find some file names:

    /usr/lib/libgtkhtml-2.so.0 /usr/lib/libgtkhtml-3.8.so.15
    /usr/lib/libgtkhtml-2.so.0.0.0 /utsr/lib/libgtkhtml-3.8.so.15.3.7

    then delete the broken symbolic link:

    rm libgtkhtml-2.so.0

    and make the new symbolic link to the latest shared object assiciated with the library that is linked:

    ln -s libgtkhtml-2.so.0.0.0 libgtkhtml-2.so.0.0.0

    for each broken link reported in the log file.

    You may uninstall any other old development library for gtk+2.0, defore to install the new development library, this is anohter source of problems.

    Search for any other devel library in rmp.pbone.net, until can compile your program!

  7. #7
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    207

    Question

    I'm just making sure, since I don't use the free version I can't tell : event if mandriva's official mirrors don't propose most -devel packages, won't the mirrors proposed by the PLF ( http://easyurpmi.zarb.org ) do that ?:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •