Find the answer to your Linux question:
Results 1 to 4 of 4
i have problem with installing glib-2.8.3. ./configure - ok but after make it says : fa.po:95: 'msgstr' is not a valid C format string, unlike 'msgid' fa.po:240: 'msgstr' is not ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Posts
    12

    installing glib


    i have problem with installing glib-2.8.3.

    ./configure - ok but after make it says :

    fa.po:95: 'msgstr' is not a valid C format string, unlike 'msgid'
    fa.po:240: 'msgstr' is not a valid C format string, unlike 'msgid'
    fa.po:245: 'msgstr' is not a valid C format string, unlike 'msgid'

    then, i type make install and it install sth because i deleted files glib-2.0 from /usr/local/lib and it turns up once more but it is also named with glib-2.0. what is more program i wanted to install - pango-1.10.0 says a have glib only in version 2.2.3 and i cant install it :/
    iam gettin annoied with all this requirements....

    can sb help me with that? i need glib to install gtk+-2.8.0, and im newbie....
    plz

    have mandrake 9.2

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Setup urpmi by following these directions

    Now as root in the terminal, do the following:
    Code:
    urpmq glib
    urpmi whatever_package_name_urpmq_returns
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Nov 2005
    Posts
    12
    ok, thx i will try and let you know if it works
    thx


    btw. do ia have to download all listed there files?

    Source contrib : Some packages made by voluntaries or Mandriva, no support, no update for it.
    Source main : The core of the Mandriva Linux distribution
    Source updates : Official updates for Mandriva Linux, including security updates
    Inne źródła::
    Source club :
    Source jpackage :
    Source plf-free :
    Source plf-nonfree :

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    No, you don't have to download all listed files that urpmq spits out, just the necessary ones. But you should set up urpmi so that it searches all avaliable mirrors close to you for the required files.
    Life is complex, it has a real part and an imaginary part.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •