Find the answer to your Linux question:
Results 1 to 8 of 8
NetHack 3.3 (Falcons Eye) is a game (RPG) that is located here http://users.tkk.fi/~jtpelto2/nethack.html i read the instructions... but alas... i havent a clue as to how i do what they ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! El-Daveo's Avatar
    Join Date
    Nov 2005
    Location
    Home
    Posts
    42

    NetHack 3.3 old game.. i need help installing


    NetHack 3.3 (Falcons Eye) is a game (RPG) that is located here http://users.tkk.fi/~jtpelto2/nethack.html i read the instructions... but alas... i havent a clue as to how i do what they ask me to do. anybody that can translate these into english for me (there in english but i dont understand them ) it would be greatly appreciated, i really wanna play the game.. i just dunno how to make it "compile" as they say.. i have it all "unziped" (it came iin a zip file off of sourceforge.com) it is Linux compatable. the "help files" are located here.. please assist

  2. #2
    Linux Newbie mindblast's Avatar
    Join Date
    Nov 2005
    Location
    iasi, RO
    Posts
    132
    Maybe you have to compile it... Maybe is the source code.
    Code:
     # cd /directory of the game/
     # ./configure
     # make
     # make install

  3. #3
    Just Joined! El-Daveo's Avatar
    Join Date
    Nov 2005
    Location
    Home
    Posts
    42
    I tried everything... i keep getting errors (ive unzipped it 2 times) the files keep screwing up .. im so F***** P-O'ed its not even funny.. illl give you the error later.. i gotta get ready for skool

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    Luton, England, UK, Earth
    Posts
    639
    The download could possibly have corrupted, try downloading it again

    Might help ya :P

  6. #5
    Just Joined! El-Daveo's Avatar
    Join Date
    Nov 2005
    Location
    Home
    Posts
    42
    ill do it again .. but alas.. ive done it 20 times before, downloading that is

  7. #6
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    I just compiled it from source and got it working. Before you can compile nethack you need to download and compile a programme called yacc produced by Berkley.

    Find it here.

    It has very few dependencies and this should help you get nethack working.

    You might need to tweak a few settings here and there to really get going, so read everything carefully.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  8. #7
    Linux Newbie mindblast's Avatar
    Join Date
    Nov 2005
    Location
    iasi, RO
    Posts
    132
    For the moment ican't download the file. The site dosen't work well for me. But i remmember i downloaded once that game and work fine. Try to compile it. In a console give commands:
    Code:
     # cd /directory/where/you/downloaded/the/archives
     #tar xvzf packet.tar.gz
     (or #tar xvjf packet.tar.bz2 (if the archive is .tar.bz2))
     # ./configure 
     # make 
     # make install
    If something go wrong, send us the error.

  9. #8
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Quote Originally Posted by mindblast
    For the moment ican't download the file. The site dosen't work well for me. But i remmember i downloaded once that game and work fine. Try to compile it. In a console give commands:
    Code:
     # cd /directory/where/you/downloaded/the/archives
     #tar xvzf packet.tar.gz
     (or #tar xvjf packet.tar.bz2 (if the archive is .tar.bz2))
     # ./configure 
     # make 
     # make install
    If something go wrong, send us the error.
    That won't work for compiling Falcon's Eye because there's no configure script. It's more complicated than that because you have to change directories all the time. As always, it's very important to read the manual. BUT ... the manual is also misleading because it doesn't mention that you must have yacc installed first.

    Anyway, I managed to compile it, but then it hung so I deleted it. You need to ensure that you have the right version of SDL installed. Maybe I'll try again later on. El Daveo got me curious about this one.

    You could try installing SlashEm instead. It's a smaller version.

    EDIT: This is my top tip. Look for rpm versions of the games you want to play. I found an rpm of SlashEm from their site. It says it's meant for Fedora Core, but I'm actually playing it now. It installs itself as gtkhack.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •