I apologize for the x-post in newbie but I really need this fixed and I dont what to do beside reinstall it






I'm a VERY new Linux user using Mandriva 2005LE and I have been trying to get my
Wireless to work and I found this on one of the forums:


Step Two:
Install the Kernel source from your Linux CD: Put the cd or dvd into the drive and use the following code in your terminal:

Code:
urpmi kernel-source gcc cvs


Step Three:
Download the Madwifi Drivers, which are open source drivers for a lot of commercial WNIC s . you can either download them by following this link :
(DELETED LINK)
or by using your terminal and this code:

Code:
cvs -dserver:anonymous@cvs.sourceforge.net:/cvsroot/madwifi login


press return when asked for a password, then

Code:
cvs -z3 -dserver:anonymous@cvs.sourceforge.net:/cvsroot/madwifi co -P madwifi


this step will download the source for the madwifi drivers.

Compile the source code by using this code in the terminal:
and be notified that madwifi is the directory of the downloaded drivers.
Code:
cd madwifi
make
sudo make install

this will place the drivers in : /lib/modules/2.6[version]mdkcustom/net . the files need to be moved to /lib/modules/2.6[your kernel version]mdk/ ,for example, the kernel version of the Mandriva where this process was tested is 2.6.11-6smpmdk so it would be:

Code:
cp –rf /lib/modules/2.6.11-mdkcustom/net/* /lib/modules/2.6.11-6smpmdk/kernel/net


to know which version is your kernel and replace it in the previous string, go into /lib/modules/ and type :
Code:
ls

then your kernel should be listed .

Step four:
Append the module configuration script with the following line, in order to auto-load the driver when your system starts :

Code:
cp /etc/modprobe.conf /etc/modprobe.conf_backup
echo “alias ath0 ath_pci” >>/etc/modprobe.conf
depmod –a


finally, load the driver:
Code:
modprobe ath_pci


Step five:
Goto Mandriva’s control center, select network configuration, and make sure you can see the WNIC selected.
Fill in the configuration .
Press apply.
Now open the terminal and use this code:

Code:
ifconfig ath0 up


this is to wake up your network configuration.

Now go back to the control center and click on wireless networks, you should be able to see the networks available , from here on you should be able to continue.





I started to do the steps and when I came to the loading the driver (modprobe ath_pci) I got this error message.

WARNING: /etc/modprobe.conf line 8: ignoring bad line starting with '?alias'
FATAL: Module ath_pci not found.

I then tried to restart the system and while looking at the "verbose mode" I kept seeing that same message pop up and I was only allowed to work in the text only mode (non GUI). I tried to fuss with the setting in XFdrake but nothing work so I simply reinstalled and everything was fine. I went once again to try those steps and the same error code appeared now linux once agian wont boot except in text only (I am dual partitioned with windows) Is there anyway I can fix this error?
_________________
-C. Scott-

Mandriva 2005LE