Firstly thanks for all the help I am abou to recieve. I am a newbie to Linux (< 1 week) and I have attempted to read all previous threads for this problem I am having.

My Hardware

Compaq Presrio 1200 Laptop
CPU P3 650
128 MB ram pc 100
Cyberblade 4 MB video card
Xircom Credit card ethernet 10/100 pci card
Motorola surfboard cable modem

Note I previously had Windows XP running on above system with internet working fine. Have formated HDD and installed new OS

OS

Mandrake 10.1
BPAlogin 2.0.2.1 i386 RPM installed
No other third party software installed

Problem

I am unable to get a network connection established. During the installation and configuration of the OS, (in particular the internet set up phase) it appeared to detect my Xircom ethernet card and labled it as "eth0 xircom CE-3 - 10/100 fast ethernet".

Once OS installed and configured, using a tutorial from "sourceforge.net" and "Australian Linux Journal" I attempted to set up a new network connection using the Mandrakelinux Control Centre > Network & internet > New Connection > Cable Connection.

The next screen displays the message "Net Device" Manually load driver
It then displays a list of various PCI cards, my particular card is not listed . I have tried several cards types 'xirc2ps_cs', 'xircom_cb' and 'pcnet_cs'... however when I click "next", a message is quickly displayed (too fast to read) and It returns to the previous screen. I have tried this with the OS install CD's in the CDROM still no difference.

I have also installed and configured the "BPAlogin" files and changed the username and password to my own, as directed in the tutorial. I have also set the network configuration to "DHCP" as specified in the tutorial.

Still I do not have a network connection, shown below is the IPCONFIG output file:

[root@localhost root]# pciconfig
bash: pciconfig: command not found
[root@localhost root]# /sbin/lspci
bash: /sbin/lspci: No such file or directory
[root@localhost root]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia] (rev 05)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 1b )
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/ C PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 0e)
00:07.4 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 20)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 21)
00:09.0 Communication controller: Conexant HSF 56k Data/Fax Modem (rev 01)
00:0a.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (re v 01)
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade i1 (rev 6a)
[root@localhost root]#

I don't know what it all means, but it appears to me that there is not a connection being established between the OS and the network card or the card is not being detected?

Lastly on the desktop screen there is a network connection icon shown with a red cross under it (obviously showing no network connected) when I right click on it a dropdown box appears with a "connect to eth0" option when i click on this nothing happens.

Please help me on this problem.. I am keen to be a full time user of Linux but am finding it a little disheartening at this early stage

Regards
Stuart