Find the answer to your Linux question:
Results 1 to 8 of 8
I just did my first Linux install of Madriva 2006 on a Gateway 450SX laptop. THe instarll went great with the exception of a constant sound fromthe sound card that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    7

    Newbie Hardware question


    I just did my first Linux install of Madriva 2006 on a Gateway 450SX laptop. THe instarll went great with the exception of a constant sound fromthe sound card that seems to start during the device initiation and go until I give up and shut down the noise is not affected by the volume control and I do not seem to be able to mute it. I tried changing the sound card drivers with no help The Madriva install was baically done n the Default settings.

    The sound card infromation is

    Audio
    Audio chipset ESS ES 1988
    Sound support PCI interface audio
    Multi-stream Direct Sound and Direct Sound 3-D acceleration
    APM1.2, ACPI1.0, and PPMI1.1 compliant
    S/PDIF output for PCM or AC-3 content via Toslink jack on port

    Can anyone help me with this? Is there iinformation that would help diagnose the issue?

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    It's possible that the constant sound is caused by just one channel which is turned up too high. Assuming you use KDE open Kmixer and play around with some of the channels. I mean turn a few down and see if that helps.

    You might try the following ones to start with:

    PCM
    Aux
    AC97

    Hope this helps.

    Edit: Another way to access channels is to open a terminal and type alsamixer. Again the assumption is that ALSA is your sound server. You use the left/right arrow keys to scroll through channels, and Esc to exit. Up/down arrow keys to adjust channel output.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Posts
    7
    Thanks for the info. I found that I can change the volume of the noise but it has to be some kind of hardware issue. I go to play a CD and I get a large amount of mechanical pink noise with no other sound cues happening at program starts or closes. I put inthe Mandriva Live CD and I do not have this issue. I also reloaded the system with no help. The info I can finde on the web would indicate that I have the right driver for the sound card so I think that is OK. I am not sure what is going on.


  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Are you using ALSA? I think that offers the best sound support.
    You might also want to search this database: http://www.alsa-project.org/alsa-doc It may offer some clues or further help.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  6. #5
    Just Joined!
    Join Date
    Jan 2006
    Posts
    7
    I am not sure if I am using ALSA or not. I working my way through the link and will try to get it downloaded and installed. Thanks for the help

  7. #6
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Quote Originally Posted by jasmeece
    I am not sure if I am using ALSA or not. I working my way through the link and will try to get it downloaded and installed. Thanks for the help
    Okay, but take things nice and slow. From the menu bar (better known as a 'kicker') look at System>Configuration>KDE>Sound>Sound System

    From inside there you can see which sound system you're using. Change to ALSA if you're not already using it. If it's not installed you might be able to do this from System>Configuration>Packaging>Install Software

    Enable duplex support while you're at it. Then review what you've done already and open a terminal. Type alsamixer and try adjusting some channels. I think it might help.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  8. #7
    Just Joined!
    Join Date
    Jan 2006
    Posts
    7
    Thanks again for the information. I found the sound settings and tried to select the ALSA drivers and I found that I have to re install them. I did find a selection that seems to work but I am going to download the drivers. I think that I need to find a good book on Linux becuase I have a bit to learn.

    John

  9. #8
    Just Joined! bigjohn's Avatar
    Join Date
    Nov 2004
    Location
    504944N, 01912W
    Posts
    66
    further to your Q about weird noises, I have to meddle with the different level settings. I like it so that I just use the volume control thats connected to the speakers.

    So with, say Kmix, I have to turn down some of the other settings - one or more of them seems to cause some sort of feedback on my system. One of the confusions being that when Kmix is open, it has settings for input, output and "switches".

    I haven't bothered to find out what all of them do, just to modify the level for the ones that have a "green light dot" above them i.e. the active ones.

    It may help, dunno?

    regards

    John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •