Find the answer to your Linux question:
Results 1 to 5 of 5
Hi there, I'm a linux noob, so I'd really appreciate a few pointers in the right direction here ... I've got Mandriva 2006 running on a laptop - the only ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    15

    Access network resources


    Hi there,

    I'm a linux noob, so I'd really appreciate a few pointers in the right direction here ...

    I've got Mandriva 2006 running on a laptop - the only peripheral the laptop has is a parallel port floppy drive. It also has a wireless LAN card, which is working well to connect to the internet via my router.

    I also have a desktop on the wireless lan which is now dual boot winxp and mandriva 2006 and has 2 x IDE CD and DVD drives - I'd really like to be able to access these drives from the laptop - it doesn't matter much to me whether I need to be running winxp or mandriva on the desktop to make this easier.

    Cheers ... Nick.

  2. #2
    Just Joined!
    Join Date
    Jan 2006
    Posts
    15
    Hum - no replies. Oh well - here's an update.

    I decided to go at this with linux running on both machines, as that sounded easier. I've set up the hosts definitions with the two machines having different names on the network, and with NFS server running on the desktop machine, and nfs-client-utils installed on the laptop.

    However, I'm now stuck: all the howto's I've found tell me that I should just be able to go ahead and mount the remote drives on the laptop (I have shared them in /etc/exports on the desktop). The mount command on the laptop just hangs.

    I've gone back to basics, i.e. ping. I can successfully ping the laptop from the desktop, but I can't ping the desktop from the laptop - again, this just hangs. The laptop definitely has network connectivity, as it can access internet, and can also ping the router.

    Can anyone help?

    Nick.

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Posts
    15
    OK, I'm getting closer.

    It turned out the earlier problem was down to the firewall on the desktop linux - temporarily switched off. Does anyone know which port I need to allow in order to get it working through the firewall?

    Anyway, I can now set mount points on the server from the client. However, I still haven't achieved my original objective of accessing the CDROM on the server.

    When I enter (as SU) on client:

    mount obiwan:/dev/cdroms /mnt/cdroms

    I get permission denied on the server. I've tried chmod-ing /dev/cdroms to 777 and setting to nouser nogroup, but no change - any ideas?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2006
    Posts
    15
    OK still no joy - and no replies. Is there anyone else in this forum??

    However, I'm inching closer ...

    - I have set up NFS shares on the server, I am sharing /, /mnt/cdrom1 and /mnt/cdrom2 - the latter two are where the cdroms are mounted.

    - I have mounted all three of these successfully on the client machine, as /mnt/obiwan, /mnt/cdrom1 and /mnt/cdrom2

    - If I point Konqueror at /mnt/obiwan (the server root), then I see the files in the server root. Good.

    - However, if I drill down through that filesystem to /mnt/cdrom1 or 2 on the server, there are no files visible - WHY? Same happens if I go via /mnt/cdrom1 or 2 mount points on the client.

    The fstab entries for the mount points on the client are identical:

    obiwan:/mnt/cdrom1 /mnt/cdrom1 nfs noatime,rsize=8192,wsize=8192, nosuid,ro, soft 0 0

    I'd REALLY appreciate some suggestions here ...

    Nick.

  6. #5
    Just Joined!
    Join Date
    Jan 2006
    Posts
    15
    WEIRD!

    I was searching desperately, and found a thread which told a similar hair-pulling story. To cut it short, I had to add the following line to /etc/fstab on the SERVER:

    nfsd /proc/fs/nfsd nfsd auto,defaults 0 0

    and then type

    mount -a

    in a server root console.

    I then unmounted and remounted on the client, and hey presto, the files were there! The sad thing is I have NO idea why that worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •