Find the answer to your Linux question:
Results 1 to 3 of 3
Hi I am writing a programme that needs to link against kdeui and kdecore libraries. I managed to install and link against kdecore as I could find the devel packages ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    22

    Installing KDE devel packages


    Hi
    I am writing a programme that needs to link against kdeui and kdecore libraries. I managed to install and link against kdecore as I could find the devel packages in my urpmi database. But I am unable to find the same packages for kdeui in my urpmi or any where else. Could you tell me where I could find this package (or is it availabel as a collection)
    I am using KDE 3.2 with mandrake 10.1 official
    thanks in advance

  2. #2
    Just Joined!
    Join Date
    Dec 2005
    Posts
    22
    Hi
    I been doing some searching it appears that the development packages are in kdelibs package. Unfortunately I cant find it in my urpmi data base I have all the data sources installed from easy urpmi. Can somebody help me regarding this issue thanks .

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    22
    H again I been trying to download and install the kdelibs package using rpm. There was a cuple of problems

    Conflicting files: I frist installed kdelibs-3.1-58mdk.i586.rpm which had some conflicting files with libkdecore-devel that was ok I used force option to sort it

    Dependencies: When I tried to install the devel package I am getting a dependency
    as follows
    Code:
    [root@x1-6-00-09-6b-40-03-e7 kdelibs]# rpm -iv kdelibs-devel-3.1-58mdk.i586.rpm
    error: Failed dependencies:
            kdelibs = 3.1-58mdk is needed by kdelibs-devel-3.1-58mdk
    but when I check for the dependent package its already there (Which I previously installed its there) heres what I did.

    Code:
    [root@x1-6-00-09-6b-40-03-e7 kdelibs]# rpm -qa |grep "kdelibs*"
    kdelibs-common-3.2.3-106.2.101mdk
    kdelibs-3.1-58mdk
    So what am I doing wrong here please reply I really need some help thanks
    wiraj.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •