Find the answer to your Linux question:
Results 1 to 3 of 3
I'm new to linux, I don't understand any codes in the DOS-like enviroment. I installed Mandriva 2006 and I can't get my modem to work. I tried to look it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    1

    Modem Problems


    I'm new to linux, I don't understand any codes in the DOS-like enviroment. I installed Mandriva 2006 and I can't get my modem to work. I tried to look it up and figure out the codes and got nowhere. Could someone Please help me out...I ran some scanmodem program and was told the following:

    PCIBUS=00:02.6

    Providing detail for device at 00:02.6
    with vendor-ID:device-ID
    ----:----
    Class 0703: 1039:7013 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0) (prog-if 00 [Generic])
    SubSystem 1849:9739 ASRock Incorporation: Unknown device 9739
    Flags: medium devsel, IRQ 18

    -----PCI_IDs------- --CompilerVer-
    Feature List: Primary Subsystem Distr KernelVer kernel default CPU
    ./scanModem test 1039:7013 1849:9739 mandrake 2.6.12-12mdk 4.0.1 4.0.1 i686
    From records, 1849:9739 has soft modem codec type SIL21
    The following two Root commands should set up the modem.
    modprobe snd-intel8x0m
    slmodemd --alsa -c YOUR_COUNTRY modem:1
    Get the SLMODEMD.gcc4.tar.gz from http://linmodems.technion.ac.il/packages/smartlink/

    The controller: 1039:7013 SIS 630
    is capable of supporting soft modem chips from AT LEAST manufacturers:
    Pctel
    AgereSystems
    Conexant
    Intel
    Smartlink
    The Subsystem has a PCTel codec SIL21
    ln -sf ttyS3 /dev/modem
    ./scanModem: line 3433: lsmod: command not found


    I don't understand what do do with the info given to me....could someone help or point me in the right direction....I really know nothing about linux but don't want to go back to windows

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    confusing isn't it.

    What you have there is a winmodem (ie. a PCI card internal modem that requires software running on the PC to do the work for it.) As your running Linux, you need to get and iinstal the Linux version of the Winmodem software driver. This is where the Linmodem stuff comes in.

    Looking at the output you will need to run two commands to set the modem up. But you will need to have the root user priveldges to run them (the root user, aka superuser, aka admin user, was that other user that you set up at instal time, and is for use when you need to instal something). To get these, you will need to open up a terminal window (aka a console). Then enter su - followed by the root password (you set that up at instal time). Please note the the command is "su" followed by a space, followed by a minus sign (su -). You'll know it worked as the last character of the command prompt changes to a # .

    Now for the commands.

    First up
    Code:
    modprobe snd-intel8x0m
    Then
    Code:
    slmodemd --alsa -c YOUR_COUNTRY modem:1
    If this gives a "can't find the command" type of error, you'll need to download "SLMODEMD.gcc4.tar.gz" from http://linmodems.technion.ac.il/packages/smartlink/ . This file is a zipped file that you can use your filemanger to unzip . There is a README file in there that tells you what to do next.

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    48

    Smile winmodem or external!!! hmmmm

    i'm sorry but if i can remember rightly, asrock is an unsupported chip but as i said i'm not sure without checking a few things.. sis630 is well supported but not if modem chip isn't. i did know of a few ppl that got some control of a winmodem like yours but with differing results and only partial control.. my answer after 3 wks of trying was to go and buy an external modem. ten minutes and your logged on line( avoid modems with rockwell chipsets). my internal was a lucent and there pretty easy to use with linux but still only partial control so throw it out and bite the bullet an buy an external... saves on panadol and gives you more cpu time...
    to check your modem chipset get vendor id and device id info and do a search for those id's. vendor obviously is the manufacturer of the device and device will tell what chip is used as well as give you a starting point for searching for a driver.. some drivers need to be compiled and that can be frustrating(i still remember the first time i compiled a driver and avoid it as much as i can. that was 7 yrs ago)

    google is quite good for searches using id's but there is a good site and i can't(for the life of me) remember it's address.. completely new computer and no bookmarks yet so sorry!!!!!!!!
    don't give up there is always a solution with linux...
    hope that helps...bye!!!!!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •