Find the answer to your Linux question:
Results 1 to 3 of 3
I have an irritating network problem. I run Mandriva 2006 on a pentium pc, connected to a LAN, and get internet access through a DSL router connected to the LAN. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4

    Problem with network access


    I have an irritating network problem.
    I run Mandriva 2006 on a pentium pc, connected to a LAN, and get internet access through a DSL router connected to the LAN.
    The problem is sometimes I find that I lost my access to the internet and to the whole LAN, when I open the NetApplet it shows that I'm not connected, I press the "Connect to internet" button, the connection fails.
    Connection comes back if I retry several times or if I restart the machine.
    If any one gets the same problem I'll appreciate his help as this problem is driving me mad.

  2. #2
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    This sounds like your network connection is set so that only root can start the connection, I had a similar problem when I first used Mandriva.

    So go to hardware configuration (HardDrake) and run the network card config tool, just keep clicking next until it asks "Do you want to allow users to start the conection?" ensure you select yes, then keep clicking next till it's finished. You will then need to restart X environment, no need to reboot, just logout of the sesion then log back in.
    This should get things working so that you are connected at boot.

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4

    Thank you darkrose0510

    I ran the wizard and found that all users are allowed to start the connection already. anyway I always login as root, the connection starts well but disconnects after a while, which requires me to use the net applet to reconnect, and so go my irritating internet sessions.

    I forgot to say that my system also insists on defining a network interface called sit0 which is referring for an unknown device, while my primary interface is eth0 for a Realtek RTL-8139 LAN card.
    Every time I erase the sit0 interface it's redefined upon system restart.

    At last I'd like to inquire why I lose connection to the loop back interface when the network connection is down? All the programs become unable to connect to localhost (127.0.0.1).

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •