I have installed linux Mandriva 10.1 on the second HDD of my computer and it is having trouble bringing up my graphical desktop. I have previously used it on my computer with a different graphics card, a Nvidia Geforce 4 and it had worked fine, but I have never got it to work on my Nvidia Fx 5900. I tried using the generic Nvidia FX drivers when installing and the generic Nvidia drivers but I have had no luck with either. When I boot up, it briefly flashes the Nvidia logo and goes to a blank desktop-like page with only a mouse and no icons. All I can do is press ctrl+alt+f1 to enter text mode. I tried typing kde in but this was all I got.

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again

[some suggestions on how to contact someone]

Xlib: connection to ":0,0" refused by server
Xlib: No protocol specified

giving up
xinit: unable to connect to X server
xinit: No such process (errno 3): server error.

I also downloaded the Nvidia driver for linux through my windows system and I have no idea of how im going to get it into my linux system.

Please help!