Find the answer to your Linux question:
Results 1 to 4 of 4
Trying to install a second hard drive on a Mandriva 2006 Free system. Every time I boot, I get an error that hdc1 has errors, and it forces me into ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    18

    Second hard drive installation issue


    Trying to install a second hard drive on a Mandriva 2006 Free system. Every time I boot, I get an error that hdc1 has errors, and it forces me into the diagnostic, which always ends up locking up. So, I dropped into maintenance mode and ran cfdisk. I deleted the existing partitions, created a new one, and rebooted. Got the same error. So, I dropped into maintenance mode and ran cfdisk again. This time I get a "segmentation fault" error and it just stops.

    So I did fdisk, deleted the partition, created a new one, and rebooted. Again, the hdc1 has errors message with the mandatory maintenance.

    Clues, anyone? Please?

  2. #2
    Just Joined!
    Join Date
    Apr 2006
    Posts
    18

    Unhappy Please...?

    Anybody . . . ?


  3. #3
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Not easy to solve. I think you should copy and paste the error messages as best you can and post them in here. Not all error messages are descriptive of the exact problem. Something to think about is how you have your hdds set up and on which IDE channels.

    I've known people to have problems when they don't have the right drives on the right IDE channels ... this can cause the kernel to become "confused" during installation. I don't think Windows is quite so fussy about this.

    Shooting in the dark a bit there, but it's a start.

    You might also want to read up about running fsck: http://www.die.net/doc/linux/man/man8/fsck.8.html

    Even if this doesn't help you with this it'll come in useful at some stage, but it can be used to repair file systems.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2006
    Posts
    18

    Got it!

    Thanks for the reply.

    I solved the problem. Yippee!

    Apparently, Mandriva doesn't like a partition unless it created it itself at installation. I reinstalled the system, and when I got to the part where the drives get partitioned, I examined the second hard drive (/dev/hdc) and discovered that despite what I'd done earlier with both cfdisk and fdisk, the partitions had never been touched. So when I reinstalled Mandrive, I formatted both hard drives over from scratch, redoing all of the partitions, and it worked like a charm. (I had a similar problem when I tried to install Mandriva the first time, with just the one drive.)

    Now if I can only get SAMBA to play nice with my Windows network . . .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •