Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
It's not working... When I typed in "chmod 555 windows" it said: "chmod: changing permissions of 'windows'; Read-only file system" Is it supposed to say this?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Apr 2006
    Posts
    9

    It's not working...
    When I typed in "chmod 555 windows" it said:

    "chmod: changing permissions of 'windows'; Read-only file system"

    Is it supposed to say this?

  2. #12
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    You should append "rw" to the -o flag on the mount command line.

  3. #13
    Just Joined!
    Join Date
    Apr 2006
    Posts
    9
    Am I supposed to use users after -orw? It didn't let me do that.

    Here's what I did so far:

    [CODE]cd /mnt.windows
    chmod 555 windows
    mount /dev/hda2 /mnt/windows -orw/CODE]

    Is there anything that I'm doing wrong?

  4. #14
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Code:
    umount /dev/hda2
    mount /dev/hda2 /mnt/windows -o users,rw
    chmod 555 /mnt/windows

  5. #15
    Just Joined!
    Join Date
    Apr 2006
    Posts
    9
    I still can't get it to work... sorry I'm such a noob at this.

    I noticed that the windows folder doesn't go away when I unmount /dev/hda2. Should I delete it before I mount it again, or does it not matter?

  6. #16
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    That doesn't matter.

  7. #17
    Just Joined!
    Join Date
    Apr 2006
    Posts
    7
    Quote Originally Posted by Calehay
    It's not working...
    When I typed in "chmod 555 windows" it said:

    "chmod: changing permissions of 'windows'; Read-only file system"

    Is it supposed to say this?
    This is OK ! This is an NTFS partition. You don't want free write access to this. This is not an error message, just an informational one, the "chmod" command didn't give write permissions anyway. Can you read the partition (browse the files, open them and copy them) now ?

    As it stands, Mandriva does not come with write to NTFS enabled. I've tried remounting the NTFS partitions "rw" to no avail. This is a safety feature of sorts. You are still able to resize NTFS partitions with diskdrake, though.

    If you want to share data between Windows and Linux, I would suggest creating a FAT partition. This is the best option because both OSes can freely read/write to this type of partition safely. In a pinch, you can use an ext2fs driver for Windows to read Linux partitions, but the FAT partition is a permanent solution.

  8. #18
    Just Joined!
    Join Date
    Apr 2006
    Posts
    9
    I can only read files in root, but not in any of the other logins.

  9. #19
    Just Joined!
    Join Date
    Apr 2006
    Posts
    7
    Quote Originally Posted by Calehay
    I can only read files in root, but not in any of the other logins.
    That's the same behavior I get when I mount from a console command line. I don't fully understand it.

    This is the console command I used : "mount -t ntfs -o users,rw /dev/hda1 /mnt/win0" after umount-ing the win partition first. After this, the directory permissions were dr-x------ (500), with owner and group = root, meaning only root can see the partition. I was unable to chown or chgrp after this with the error message "read only filesystem".

    When I umounted again and mounted as simply "mount /mnt/win0" which will use the /etc/fstab definitions, the directory was mounted as dr-xr-xr-x (555) with the same owner and group (root for both). Now I could see the partition and browse it as a normal user. Of course, write is still not possible.

    This is the line that was present in my /etc/fstab :
    "/dev/hda1 /mnt/win0 ntfs umask=0,nls=iso8859-1,ro 0 0"

    You can append it to yours (after changing the hda partition number accordingly) and run "mount -a" as root. This should solve your problem. But make sure you don't double mount - check your fstab to remove any previous lines referencing this partition first.

    I honestly don't know enough about the intricacies of mount to understand why the behaviour is different in each case. I wonder if some more knowledgeable user can enlighten us both ?

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •